Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3805 closed defect

GOB3:'A Bell' button hotspot disappears

Reported by: SF/marticus Owned by: DrMcCoy
Priority: high Component: Engine: Gob
Keywords: original Cc:
Game: Goblins 3

Description

In the final level 'Gods', after freeing the 2 hands i hit the left button and was too slow in hitting the right button so immediately headed back to the left, however the hotspot no longer showed up.

This is on windows daily build from July 11, english DOS CD verision of Gob3. The bug stays even when saving, quitting and restoring.

Ticket imported from: #2016550. Ticket imported from: bugs/3805.

Attachments (2)

gob3cd-us.s09 (19.6 KB ) - added by SF/marticus 11 years ago.
Save with hotspot gone
gob3cd-us.s08 (19.4 KB ) - added by SF/marticus 11 years ago.
Save just before bug occurred

Download all attachments as: .zip

Change History (11)

by SF/marticus, 11 years ago

Attachment: gob3cd-us.s09 added

Save with hotspot gone

by SF/marticus, 11 years ago

Attachment: gob3cd-us.s08 added

Save just before bug occurred

comment:1 by SF/marticus, 11 years ago

File Added: gob3cd-us.s08

comment:2 by SF/marticus, 11 years ago

Summary: 'A Bell' button hotspot disappearsGOB3:'A Bell' button hotspot disappears

comment:3 by sev-, 11 years ago

THis is nice to get fixed before the release

comment:4 by sev-, 11 years ago

Owner: set to DrMcCoy
Priority: normalhigh

comment:5 by DrMcCoy, 11 years ago

I can't confirm this with either of my versions.
The hotspot disappears when the hand is on the chain (menu and saving is disabled there), but reappears as soon as the hand is back in the hole.

Could you retry with the current daily build and a save from before entering the Gods screen, just to be sure it's still there?

comment:6 by SF/marticus, 11 years ago

I tried it again with a new build (25/7), the only previous save I have is about 6 screens previously so haven't gone that far back.

I tried a few different things and found that the bug only occurs with the left bell not the right. All you have to do is push the right bell before the left hand finishes returning to the cave. The left hotspot which should return once the left hand is back in does not reappear. If you do it with the sides swapped, the right hotspot still reappears as expected.

comment:7 by sev-, 11 years ago

Keywords: original added; script removed

comment:8 by sev-, 11 years ago

This bugreport has been moved to Wiki to relevant Engine/TODO page. When the bug will be resolved, an appropriate message will be posted here and the bugreport link removed from Wiki

comment:9 by sev-, 11 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.