Opened 18 years ago

Closed 18 years ago

Last modified 18 years ago

#374 closed defect (fixed)

LOOM wrong pathfinding in latest cvs

Reported by: SF/isnothere Owned by: SF/ender
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

In the latest cvs (29/07/2002) bobbin doesn't seem to notice the obstacles in the field. I say him, "walk to the upper left corner of the screen" and bobbin walks STRAIGHT to that point. Screenshot included.

Ticket imported from: #588074. Ticket imported from: bugs/374.

Attachments (1)

loom_flying.png (44.9 KB ) - added by SF/isnothere 18 years ago.
screenshot

Download all attachments as: .zip

Change History (15)

by SF/isnothere, 18 years ago

Attachment: loom_flying.png added

screenshot

comment:1 by fingolfin, 18 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 18 years ago

Can't reproduce this in current CVS. Is this using the daily build, or self compiled CVS?

Do you click on a special spot, or just anywhere in the upper part of the room to make this happen?

comment:3 by SF/ignalina, 18 years ago

I can reproduce this. ScummVM 0.2.2 CVS, built on Jul 29 2002 17:51:35 (OS X). Bobbin can't quite walk *anywhere*, but the paths he follow certainly don't follow the graphics. It's like they belong to a different room or something.

comment:4 by SF/isnothere, 18 years ago

I'm using current(self compiled) cvs. Bobbin can walk anywhere you click with the mouse and he walks in a STRAIGHT line. I just gave an example of wrong behaviour by putting bobbin in the upper left corner of the screen. Confirmed with the now current cvs.

comment:5 by SF/ignalina, 18 years ago

I stand corrected. Bobbin can walk *anywhere*. I was just confused by him sometimes changing direction, as if he is aiming for some 'exit spot'. However, by the loom, where the screenshot is taken, he can't really walk anywhere until the egg has hatched. Cofirmed with current CVS.

comment:6 by SF/ender, 18 years ago

Also confirmed by myself and Khalek with latest CVS. Raising priority.

comment:7 by SF/ender, 18 years ago

Priority: normalblocker

comment:8 by fingolfin, 18 years ago

Can somebody please attach a save game? Maybe then I can reproduce it...

I am not at home till friday, so it's not likely that I can look into this before.

comment:9 by SF/isnothere, 18 years ago

It is happening right from the start. No need for a saved game. It's really strange that you can't reproduce the problem...

comment:10 by fingolfin, 18 years ago

Ah yes, opening a new game shows the problem. So far I only tried loading savegames.

The problem occurs because class 22 (ignore boxes) becomes set for Bobbin. Either Loom uses this differently, or a similar problem as in Indy3 occurs. I notices that o5_setClass has a special case for Indy3, it descreases the class value. Maybe Loom(CD) needs a similar hack. However, why is o5_ifClassOfIs not changed correspondingly I wonder? Weird. But again I can't really look into this currently.

comment:11 by SF/segra, 18 years ago

same thing happens with me, running latest CVS

click anywhere on the screen and bobbin just walks straight to where you clicked

comment:12 by SF/ender, 18 years ago

Fixed by resetting ignoreBoxes on class zero'ing.

comment:13 by SF/ender, 18 years ago

Owner: changed from fingolfin to SF/ender
Resolution: fixed
Status: newclosed

comment:14 by fingolfin, 18 years ago

Ahhh good point! Without having seen the fix yet: maybe better/simpler solution would be to get rid of my stupid classChanged() method in Actor again; then add a method ignoresBoxes, wich will do "the right thing", i.e. return ignoreBoxes and/or isInClass(22)

Note: See TracTickets for help on using tickets.