Opened 12 years ago

Closed 12 years ago

#3715 closed defect (invalid)

NDS: Screen cut off at the bottom in Monkey Island

Reported by: SF/b0n3m4n Owned by: agent-q
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Using scummvm-0.11.1 for Nintendo DS with the 4MB version of Monkey Island 1 in English. This is the only game I tried so far, I'll let you know if it happens with other games too. I'm using the M3 Real card.

The bug happens throughout the game and thus should be easily reproducible.

The resolution on the lower (complete view) DS screen is scaled wrong (not 1:1), so everything is too narrow. Additionally the image is too large in the vertical direction, causing the screen to be cut off at the bottom. This cuts away exactly one line of the inventory, causing item handling to become quite a hassle, since a switch to zoomed screen is necessary to access the bottom inventory item.

Ticket imported from: #1956683. Ticket imported from: bugs/3715.

Change History (3)

comment:1 by fingolfin, 12 years ago

Owner: set to agent-q
Summary: Video cut off at the bottomNDS: Screen cut off at the bottom in Monkey Island

comment:2 by agent-q, 12 years ago

Resolution: invalid
Status: newclosed

comment:3 by agent-q, 12 years ago

Please read the instructions! Your question about the lower row of the inventory is question 1 in the FAQ!

The screen is scaled only horizontally for performance reasons. Therefore he aspect ratio is not perfect, but only close to how it should be. This is as intended.

Note: See TracTickets for help on using tickets.