Opened 12 years ago

Closed 11 years ago

Last modified 4 years ago

#3697 closed defect (fixed)

AGI: Fan(Get Outta SQ) - Graphics messed up

Reported by: raziel- Owned by: m-kiewitz
Priority: low Component: Engine: AGI
Keywords: original script Cc:
Game: AGI Fanmade

Description

ScummVM 0.12.0svn (Apr 14 2008 21:18:32) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

the third one

When the intro screen "GET OUTTA SPACE QUEST by Joey Rinella and Jon Swiderski" comes up, one can wait for the next screen (black with some text on it) to come up AND wait even more to get the intro screen mentioned above looped.

Problem is the reloaded intro screen is now messed up, sometimes worse than before, it is being looped by a shaking of the screen.

Seems like a script/graphics combination bug?

Fanmade AGI game (Get Outta Space Quest/DOS/English)

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1942484. Ticket imported from: bugs/3697.

Attachments (1)

AGI_OuttaSQ_IntroNormal.png (11.3 KB ) - added by raziel- 12 years ago.
intro screen

Download all attachments as: .zip

Change History (14)

by raziel-, 12 years ago

Attachment: AGI_OuttaSQ_IntroNormal.png added

intro screen

comment:1 by raziel-, 12 years ago

Tested with DOSBox 0.70 and "Sierra.com" provided with the archive. AGI interpreter v2.936 doesn't run the game.

In the original the screen is simply shaken again after some time and the (c) string is added to the bottom of the game window. No graphics corruption.

comment:2 by sev-, 11 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:3 by sev-, 11 years ago

No, it does not relate to flawed word wrapping implementation. In fact it just did not even attempted to perform any wrapping at that place.

Fixed in SVN

comment:4 by sev-, 11 years ago

Oops. Wrong ticket. Now I really obliged to fix it :)

comment:5 by sev-, 11 years ago

Resolution: fixed
Status: closednew

comment:6 by sev-, 11 years ago

Could you, please, provide screenshot from ScummVM? Seems that I cannot reproduce it here.

comment:7 by sev-, 11 years ago

Keywords: original added

comment:8 by sev-, 11 years ago

Aha. Running under dosbox pretty soon lead to message:

"Script buffer overflow. Maximum size = 50. Press ESC to quit."

So it is in fact bug in the original.

comment:9 by sev-, 11 years ago

Priority: normallow

comment:10 by sev-, 11 years ago

Status: newclosed

comment:11 by sev-, 11 years ago

This bugreport has been moved to Wiki to relevant Engine/TODO page. When the bug will be resolved, an appropriate message will be posted here and the bugreport link removed from Wiki

comment:12 by m-kiewitz, 4 years ago

Keywords: script added
Owner: changed from sev- to m-kiewitz
Resolution: fixed

comment:13 by m-kiewitz, 4 years ago

The scripts try to draw the title somewhere outside of the screen. This resulted even in memory corruption in original AGI. I now added checks to ignore such screen objects, which means the screen is simply black when it happens in this game. A warning is also given to the user.

It's a game bug anyway.

commit 587c1ad3106752e703197f8063bf03a0fb877561

Note: See TracTickets for help on using tickets.