Opened 11 years ago

Closed 11 years ago

#3681 closed defect (fixed)

PQ1: Predictive Text does not load

Reported by: SF/jakekusters Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Police Quest 1

Description

Hi,

I am running the most recent version (English) of ScummVM on my GP2X F200.

In the save game provided the main character is standing in the middle of the cafe. When you walk to the table on the left of the screen and type "sit" the character will sit down, from here on predictive text is not accessible as it is required to type 'Stand" to answer the phone call. I have waited for a long time then pressed the key combination to access predictive text (L Shoulder + A) and this did not work. I have tried other combinations as well.

Also, it is required in the game to activate the police car's siren, however no actual button has been mapped to this. On PC the button is F10.

Ticket imported from: #1935844. Ticket imported from: bugs/3681.

Attachments (1)

pq1.006 (1.4 KB) - added by SF/jakekusters 11 years ago.
Game save before problem occurs

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by SF/jakekusters

Attachment: pq1.006 added

Game save before problem occurs

comment:1 Changed 11 years ago by sev-

Owner: set to SF/buddha_

comment:2 Changed 11 years ago by SF/jakekusters

I made a feature request for the siren keymap because that is what DJWillis said to do :).

comment:3 Changed 11 years ago by sev-

Summary: PQ 1: Predictive Text does not load and no siren buttonPQ1: Predictive Text does not load and no siren button

comment:4 Changed 11 years ago by bluegr

Summary: PQ1: Predictive Text does not load and no siren buttonPQ1: Predictive Text does not load

comment:5 Changed 11 years ago by bluegr

Removed the siren button part of the bug report title, as a separate feature request has been filed for this

comment:6 Changed 11 years ago by bluegr

I've changed the predictive dialog to show up when the player cannot be controlled, which should fix the issue you're having. Can you please test the latest SVN version to check if it's working for you now?

comment:7 Changed 11 years ago by bluegr

Owner: changed from SF/buddha_ to bluegr

comment:8 Changed 11 years ago by SF/jakekusters

Yay fixed! :D

Thanks for the help, much appreciated.

(Fixed in SVN build)

comment:9 Changed 11 years ago by SF/jakekusters

Resolution: fixed

comment:10 Changed 11 years ago by sev-

Status: newclosed
Note: See TracTickets for help on using tickets.