Opened 18 years ago

Closed 18 years ago

Last modified 18 years ago

#368 closed defect (worksforme)

MI2: Bug with dancing skeletons

Reported by: SF/forumjoe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 2

Description

When guybrush passes out after attempting to climb the tree, he dreams of dancing skeletons. These skeletons start singing a song, and halfway through the song they do a little dance. On my current version, one particular dance move just keeps getting repeated. They don't stop dancing, even when the singing is supposed to start again (they don't start singing again) or even by the end of the song, they're just walking back and forth on the screen.
There's no way to end the dance, or get any further.

I'm currently running scummvm 0.2.0 for win32, and I downloaded the daily snapshot for 22 July, and that didn't fix the error. The version of Monkey Island 2 I'm playing is the one that comes on CD with Monkey Island 1. Scummvm claims it's monkey island 2 version 5.2.2, I'm playing it in english

Ticket imported from: #585233. Ticket imported from: bugs/368.

Attachments (2)

monkey2.s01 (46.2 KB ) - added by SF/forumjoe 18 years ago.
monkey2.s02 (45.8 KB ) - added by SF/forumjoe 18 years ago.
Save game DURING bug

Download all attachments as: .zip

Change History (11)

comment:1 by SF/forumjoe, 18 years ago

Summary: Bug with dancing skeletonsMI2: Bug with dancing skeletons

comment:2 by SF/khalek, 18 years ago

Can you attach a savegame shortly before this happens? The version number scummvm prints out is a fixed string in scummvm by the way, so anyone who runs monkey2 will get told the game is scumm v 5.2.2

by SF/forumjoe, 18 years ago

Attachment: monkey2.s01 added

comment:3 by fingolfin, 18 years ago

Can't reproduce this here.

Do you have sound or music disabled by chance?

comment:4 by SF/forumjoe, 18 years ago

I don't have sound or music disabled. I haven't changed any of the default options. It is just misbehaving...

by SF/forumjoe, 18 years ago

Attachment: monkey2.s02 added

Save game DURING bug

comment:5 by SF/forumjoe, 18 years ago

I have just uploaded another save game. This is saved during the bug, while they're just going back and forth. Load that up and see what they are doing.

comment:6 by SF/khalek, 18 years ago

ok.. I can't reproduce this myself, but I can load your second save game to see what you mean. It is possible to get further from the state of the game in your second save game, end the cutscene by hitting escape. Not sure what could be causing the game to go into this state in the first place, and don't have the time to check right now. If escape doesn't work reply and I'll attach a savegame as a tempory workaround for you.

comment:7 by SF/forumjoe, 18 years ago

Thankyou for your attempts. The escape does work, so I can continue playing the game (though the escape key only works if I press it before the bug takes place). Thanks anyway.

comment:8 by fingolfin, 18 years ago

Since nobody can reproduce it currently, I will close this bug now.

comment:9 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.