Opened 13 years ago

Closed 13 years ago

#3663 closed defect (fixed)

HoF: quirks in end credits

Reported by: SF/clemty Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 2

Description

win32 svn 21 Mar

HoF game is completable, however there are some gfx quirks in the end credits.

first slide (mountaineers) seems ok second slide (herb's shack) is garbled third slide (fishing) looks ok forth slide (sheep) shows for a splitsecond, then ScummVM exits for me.

all images seem very far to the left, but I assume this was so in the original as well

Ticket imported from: #1922556. Ticket imported from: bugs/3663.

Attachments (1)

herbs.png (77.4 KB ) - added by SF/clemty 13 years ago.
ending credits - herb's shack - gfx garbled

Download all attachments as: .zip

Change History (9)

by SF/clemty, 13 years ago

Attachment: herbs.png added

ending credits - herb's shack - gfx garbled

comment:1 by SF/clemty, 13 years ago

Owner: set to lordhoto
Summary: HoF: quriks in end creditsHoF: quirks in end credits

comment:2 by lordhoto, 13 years ago

Owner: changed from lordhoto to athrxx

comment:3 by lordhoto, 13 years ago

Component: Engine: Kyra
Game: Kyrandia 2

comment:4 by athrxx, 13 years ago

Thanks for your report. The graphics alignment to the very left is normal. Not the rest, though. Neither me nor LordHoto seem to be able to reproduce this bug atm. Does the outro alway look exactly like this for you? Or is there a different behaviour from time to time? What are your system specs? Please upload the save game that you use to run the outro.

Florian

comment:5 by SF/clemty, 13 years ago

just tried it again with today's SVN and I can't replicate it any more.

However, if I click once to "fast-forward" through the text while they're talking at the end, the credits sequence terminates immediately every time. I think in the original clicking only skipped one line of text when talking and should not affect the credits sequence?

(Win XP, win32 SVN version, Athlon64 3200+)

comment:6 by athrxx, 13 years ago

okay, since that wsa glitch can't be replicated even by you I assume that this is not an issue any more. Please report if you encounter this again (or just tell us in irc).

I just checked with DosBox and Unz: Clicking once during credits playback should jump to the voice actor credits (CD-ROM version) or to the Malcolm/junkyard scene (other versions). I committed some code to match the behaviour of the engine to the original and to improve handling of the skip flags within the intro and credits in general. Please check this out before I close the item.

Note, that the original will still complete the current credits scene before skipping the rest. I did't implement it like that for now since I don't think we should. The original also doesn't support skipping of the junkyard scene which I think we should keep.

comment:7 by athrxx, 13 years ago

Status: newpending

comment:8 by athrxx, 13 years ago

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.