Opened 17 years ago

Closed 17 years ago

Last modified 10 months ago

#366 closed defect (fixed)

Pause mode doesn't stop music anymore

Reported by: fingolfin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

In current CVS, pausing the game (via space or by
showing the GUI via F5 or F7) doesn't pause the music
anymore. I guess that it is caused by the recent iMuse
pause mode patch in CVS. No time to investigate further
right now (need to sleep :-)

Ticket imported from: #584684. Ticket imported from: bugs/366.

Change History (5)

comment:1 by SF/khalek, 17 years ago

Can't reproduce this with either monkey2, dott or foa with
latest cvs, x86 linux/g++

comment:2 by fingolfin, 17 years ago

To quote sound.cpp:

/* Arisme : do not pause iMuse as this will disable synch
events */
/* the sound is really "paused" in the mixer */

However, this is not correct when one uses a "real" midi
driver, like CoreAudio or QuickTime Midi on MacOS, or ALSA
on Linux - they bypass our mixer after all.

comment:3 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:4 by SF/arisme, 17 years ago

oops, sorry ... will think twice before submitting my next
"simple" patch :)

comment:5 by digitall, 10 months ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.