Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3646 closed defect (invalid)

PSP/FW: Scummvm crashes before Intro

Reported by: SF/nolange Owned by: joostp
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

I tried running the english Amiga-Version of "Future Wars" on ScummVM 0.11.1 - PSP Port.
The game starts, asks for the copyprotection, then displays the delphine logo - after that scummvm crashes to the XMB.
Same game works fine (ie shows intro, game starts) on the Windows ScummVM.

Tried disabling music, didnt make a difference.

Ticket imported from: #1907706. Ticket imported from: bugs/3646.

Change History (5)

comment:1 by fingolfin, 12 years ago

Owner: set to joostp

comment:2 by joostp, 12 years ago

Sounds like an unaligned access to me... I don't have this game, is there a demo available with which this is reproducible?

comment:3 by joostp, 12 years ago

Actually, if it goes back to the XMB then it probably isn't crashing.
The next suspect would be the number of simultaneously opened files, which is limited on PSP. How many files does this game have? Can you list them?

comment:4 by SF/nolange, 12 years ago

Are you familiar with Murphy`s Law?

It turns out theres nothing wrong with it, except that I assumed the copyprotection to be removed. When I tried the Game on Windows I mustve hit the right combination by luck - and that 2 consecutive times. How are the odds for that? (20736:1 according to my calculator)

So the game runs fine on PSP - it just that I dont plan to carry the manual around for copyprotection =(

comment:5 by SF/nolange, 12 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.