Opened 13 years ago

Closed 12 years ago

#3624 closed defect (fixed)

SYMBIAN: The Dig crashes on Symbian 9.1 FP1

Reported by: SF/alckras Owned by: anotherguest
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Hi, in my Samsung i560 with Symbian OS 9.1 FP1 (like N95) the game crashes every about 10 minutes and gives me an "SDL_4" error. But i restart ScummVM and play another 10 minutes. The big problem is when i arrived to the new world. ScummVM gives me an error "SDL_4" and 2 seconds later crashes, and then, gives me an other error "SDL_a" and i cant continue any more. I can load a savegame, but at the same point the game crashes.

I tested with the last version and older versions, and crashes at the same point.

Also freeze for 20 seconds after begin or load a savegame.

The game is in Spanish and compressed in MP3. I attach a savegame at this point (version 0.11.0).

Thanks.

Ticket imported from: #1893026. Ticket imported from: bugs/3624.

Attachments (1)

dig-es.s02 (25.7 KB ) - added by SF/alckras 13 years ago.
Savegame at new world

Download all attachments as: .zip

Change History (9)

by SF/alckras, 13 years ago

Attachment: dig-es.s02 added

Savegame at new world

comment:1 by SF/alckras, 13 years ago

Ok, i have been some tests and the problem is in the .bun files, because without digvoice.bun and digmusic.bun the game runs fine. I had compressed this files in ogg and mp3 changing various atributtes, and the result is the same. The file causes crashes is digmusic.bun, but i have no idea how to fix this.

comment:2 by bluegr, 13 years ago

I believe this is a duplicate to #1787316 - "SYMBIAN: DIG crashes on Nokia N73", as the N73 and the N95 have the same version of SymbianOS

comment:3 by fingolfin, 13 years ago

Owner: set to anotherguest

comment:4 by fingolfin, 13 years ago

Priority: normalhigh

comment:5 by sev-, 12 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:6 by anotherguest, 12 years ago

Resolution: fixed

comment:7 by anotherguest, 12 years ago

Crashes because background music needs to restart, and filesession pointer is invalid. Fixed by storing the filesession pointer when starting ScummVM. SDL_4 is usually the audio thread in ScummVM.

Still I had a couple of randon crashes on target, but those might be for other reasons. Memory should not, since running The Dig requires approx 6 mb of free memory which should be fine for most devices.

Perhaps the MP3 or OGG handling might also be somewhat unstable. Still this background sound crash is valid for all versions of the The Dig regardless if the audio is compressed or not.

comment:8 by sev-, 12 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.