Opened 12 years ago

Closed 12 years ago

#3623 closed defect (fixed)

LURE: Assertion on loading (hotspots)

Reported by: raziel- Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM 0.12.0svn (Feb 11 2008 11:04:12) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

On loading the attached save game i get assertion "_data" failed: file "./engines/lure/hotspots.h", line 442

Might be a broken save game though, haven't played upto this point since then.

Lure of the Temptress (English/DOS)

AmigaOS4 gcc version 4.2.2 (AmigaOS build 20070219)

Ticket imported from: #1891897. Ticket imported from: bugs/3623.

Attachments (1)

lure.008 (21.7 KB ) - added by raziel- 12 years ago.
just load it

Download all attachments as: .zip

Change History (6)

by raziel-, 12 years ago

Attachment: lure.008 added

just load it

comment:1 by jvprat, 12 years ago

Owner: set to dreammaster

comment:2 by raziel-, 12 years ago

The 0.11.0 palindrome release doesn't come up with an assertion, it loads the file fine (though, due to a not yet fixed - in 0.11 - hotspot bug, the characters are stuck in the sewer outlet room)

Hope that helps

comment:3 by raziel-, 12 years ago

Summary: LURE: Assertion loading (hotspots)LURE: Assertion on loading (hotspots)

comment:4 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed

comment:5 by dreammaster, 12 years ago

I've applied a fix to resolve the hotspot load crash. As for the stuck problem, it seems to be that the room entrance is marked as if someone was standing there, even though there is no-one there now. Unfortunately, there's not much I can do to diagnose the problem, since it's already happened. It is, however, possibly something already fixed, since your savegame was from a rather older version 0.26, and there have been many fixes since then.

If it happens again in the latest code, open a new bug entry and I'll look into it further.

Note: See TracTickets for help on using tickets.