Opened 12 years ago

Closed 11 years ago

#3618 closed defect (invalid)

MI2: Crashes when entering Stan's shop

Reported by: SF/islander2 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I'm using Scumm version 0.11.0.

Crashes (SCUMM freezes and then eventually quits) when entering Stan's shop on Booty island (I'm just outside it on the attached savegame). I have tried playing from the CD and from the hard drive files, but both produce the same result.

English language version.

The regular (DOS) version bundled on the Bounty pack CD.

MAC OSX 10.4.11 (intel Macbook)

Ticket imported from: #1891362. Ticket imported from: bugs/3618.

Attachments (2)

monkey2.s04 (34.0 KB ) - added by SF/islander2 12 years ago.
Savegame just before the problem
ScummVM Preferences (1019 bytes ) - added by SF/islander2 12 years ago.
Scumm prefs

Download all attachments as: .zip

Change History (14)

by SF/islander2, 12 years ago

Attachment: monkey2.s04 added

Savegame just before the problem

comment:1 by eriktorbjorn, 12 years ago

There's something strange about that savegame. When I load it, I don't hear any music, and I don't get any mouse cursor. Leaving he room causes ScummVM to hang. I don't have the time to look any further, at least not right now.

comment:2 by fingolfin, 12 years ago

Hm, what music driver have you set up?
Maybe you could attache your "ScummVM Preferences" file, too?

comment:3 by fingolfin, 12 years ago

Summary: Crashes when entering Stan's shopMI2: Crashes when entering Stan's shop

by SF/islander2, 12 years ago

Attachment: ScummVM Preferences added

Scumm prefs

comment:4 by SF/islander2, 12 years ago

Hi folks, thanks for the responses.

Fingolfin- I was originally using the core audio driver, but disabled it as I haven't been able to get the music working (I couldn't find a soundfont for the MIDI) , and had read on an old thread that the music drivers caused crashes here. Didn't make any difference though.

Eriktorbjorn- when I selected Macintosh as the platform in the scumm menu, I didn't get a mouse cursor, but got one when I switched this option to Apple llgs.

Sorry if this isn't helpful- frankly, I don't know the first thing about programming!

I'll attach my prefs, thanks again.
File Added: ScummVM Preferences

comment:5 by SF/islander2, 12 years ago

Aha!

I switched the platform to DOS (this option is actually to indicate what platform the game was originally designed to work on, right?) and I don't get a mouse cursor, BUT the game doesn't crash when entering Stan's..

comment:6 by eriktorbjorn, 12 years ago

The savegame problems could be related - or at least similar - to bug #1508095 ("SCUMM: Potential savegame incompatibility"). Fingolfin, do you suppose messing with the platform setting is enough to cause the original problem?

comment:7 by fingolfin, 12 years ago

I don't see how messing with the platform problem in this particular case should cause a problem (also in general, it can -- maybe we should move those settings to and "Advanced" tab with a message saying "Only touch these if you know what you are doing" ;-) ).

But I don't claim to have checked this thoroughly, so maybe it could, after all.

Also, using a different MIDI driver could cause these problems, which is why I asked for this. In particular, from "ScummVM Preferences" I can tell that MI2 was set to the "null" MIDI driver for islander2. Oops. So, this could very well be the cause for the broken savegame. Very bad issue. We really need to resolve this :/

comment:8 by fingolfin, 12 years ago

Priority: normalhigh

comment:9 by sev-, 11 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:10 by sev-, 11 years ago

Keywords: script removed

comment:11 by Kirben, 11 years ago

Closing as invalid, the freeze (infinite loop) occurs because the music engine has been disabled (by setting platform to Apple IIgs), and the game (especially this part) relies on music timing.

There is already a separate bug report open, for the saved game compatibility problems, when the music driver is changed.

comment:12 by Kirben, 11 years ago

Owner: set to Kirben
Priority: highnormal
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.