Opened 12 years ago

Closed 12 years ago

#3617 closed defect (fixed)

GOB3: Buggy Blount movement on stairs

Reported by: SF/madman15 Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

On every stairs Blount moves "slow" - he changes his movement direction very often, so it takes some time to go downstairs. Movement upstairs is OK. This bug makes game uncompletable - you can't pick up Xena ancestor's slipper.

Ticket imported from: #1888627. Ticket imported from: bugs/3617.

Change History (6)

comment:1 by SF/madman15, 12 years ago

Summary: Buggy Blount movement on stairsGOB3: Buggy Blount movement on stairs

comment:2 by bluegr, 12 years ago

I don't know about the issue with the stairs, I personally didn't notice such a thing myself.

Concerning the slipper: it's not a bug, and the game is completable. You'll have to use the chandelier to get down to the slipper once it's dropped. Refer to bug #1705220: http://sourceforge.net/tracker/index.php?func=detail&aid=1705220&group_id=37116&atid=418820 and this forum post: http://forums.scummvm.org/viewtopic.php?t=3787

drmccoy is the gob engine maintainer, and he can provide more information on this, but I believe this is a duplicate of bug #1705220

comment:3 by DrMcCoy, 12 years ago

Owner: set to DrMcCoy

comment:4 by DrMcCoy, 12 years ago

Hmm, the chandelier thing is AFAIK the correct solution, but Blount does walk down the stairs differently (and slower) than in the original interpreter. I think I'll have to go through the walking functions again.

comment:5 by DrMcCoy, 12 years ago

Fixed the issue in the SVN repository, Blount walks down the stairs correctly now.

comment:6 by DrMcCoy, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.