Opened 11 years ago

Closed 11 years ago

#3599 closed defect (invalid)

AGI: Naturette 3: crash in intro

Reported by: (none) Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

When playing on Naturette 3

insertion failed. v->numLoops>- n, file engines/agi/view.cpp line 287

adnormal program termination.

It happened at the end of the intro.

ScummVM v0.11.0 windows version.

You can find Naturette 3 at:
http://membres.lycos.fr/agisite/rette3.htm

Ticket imported from: #1880745. Ticket imported from: bugs/3599.

Change History (10)

comment:1 Changed 11 years ago by sev-

Owner: set to SF/buddha_

comment:2 Changed 11 years ago by sev-

Kari, may you take a look at it?

comment:3 Changed 11 years ago by sev-

Summary: crashes on Naturette 3 (agi fanmade game)AGI: Naturette 3: crash in intro

comment:4 Changed 11 years ago by SF/buddha_

Downloaded the game from the given URL, added it to ScummVM,
ran the intro on 0.11.0 and on the current SVN trunk,
tried both french and english texts, but still
I could not reproduce this bug. Nothing crashed...

I presume you mean the end of the intro is when you can first
control the protagonist i.e. just after she has followed the
little green man on the leaf to the next screen (onto the beach
with the tentacles in the water)?

P.S. I'm using Windows 2000 here if it matters.

comment:5 Changed 11 years ago by (none)

Hi

Because I couldn't use the mouse (ScummVM can't see this game uses agimouse), I used the debugger mode by pressing alt+D, type TP and 227. It also happened with Nagi and AGI.

Sorry for the false report.

comment:6 Changed 11 years ago by SF/buddha_

Please, Eugene, do your magic :).
I'm not yet sufficiently versed in the lore of bug report
administration to know the intricacies of what to do in
this particular situation.

I'd venture Resolution -> Invalid and Status -> Closed,
would that be ok?

comment:7 Changed 11 years ago by SF/buddha_

Owner: changed from SF/buddha_ to sev-

comment:8 Changed 11 years ago by (none)

It's o.k. for me. I still use the debug tricks but this time, ScummVm works. It didn't crash.

comment:9 Changed 11 years ago by sev-

Kari, yes, this is the way to go. Closing

Robin, there were palette-related glitches reported. If possible, please, submit the bugreports for those bugs as well.

comment:10 Changed 11 years ago by sev-

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.