Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3566 closed defect (wontfix)

MI2 demo: from the demos page fails during intro

Reported by: SF/eerot Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Steps to reproduce:
- Download the English Monkey Island 2 DOS demo from:
http://www.scummvm.org/demos.php
- Extract and run it under ScummVm (v0.9 or 0.11)

Result:
- <10 seconds into the intro, ScummVm opens a debugging console and complains about "room 5 not in room 5"

Is this file corrupted?

(I tried this twice. About everything else seems to work just fine.)

Ticket imported from: #1874080. Ticket imported from: bugs/3566.

Change History (7)

comment:1 by sev-, 12 years ago

As it is mentioned on our compatibility page:

- Demo version often crashes due to missing resources, since it was never meant to be playable
- No support for playing back the recorded file of gameplay in demo version

comment:2 by sev-, 12 years ago

Resolution: wontfix
Status: newclosed
Summary: M2 demo from the demos page fails during introMI2 demo: from the demos page fails during intro

comment:3 by SF/eerot, 12 years ago

I might be blind, but none of these pages mentions that:
http://www.scummvm.org/compatibility.php
http://www.scummvm.org/compatibility_stable.php
http://wiki.scummvm.org/index.php/Monkey_Island_2:_LeChuck's_Revenge
?

comment:4 by fingolfin, 12 years ago

See <http://www.scummvm.org/compatibility.php?details=monkey2>

comment:5 by SF/eerot, 12 years ago

> See <http://www.scummvm.org/compatibility.php?details=monkey2>

Ok. (damn, I hate links which are not indicated in any way)

This seems to be the only demo that has these issues. Maybe it would make sense to mention that also in the download page entry for this demo ("problems with scummvm")?

comment:6 by fingolfin, 12 years ago

Good suggestion, will update the demos page accordingly

comment:7 by Kirben, 10 years ago

Owner: set to sev-
Note: See TracTickets for help on using tickets.