Opened 12 years ago

Closed 11 years ago

Last modified 8 months ago

#3558 closed defect (fixed)

GUI distorted on Solaris/sparc

Reported by: SF/wooshell Owned by: jvprat
Priority: normal Component: Port: Solaris
Keywords: Cc:
Game:

Description

Freshly built ScummVM 0.11.0 release on Solaris 8 Sparc,
the classic GUI does not contain any resemblance of text.
The button outlines are normal, as far as I can tell, but where once was text are just lines and dots without meaning. (see attached screenshot).

Ticket imported from: #1871509. Ticket imported from: bugs/3558.

Attachments (2)

scummvm.jpg (51.0 KB) - added by SF/wooshell 12 years ago.
Screenshot of broken GUI
scummvm2.jpg (44.1 KB) - added by SF/wooshell 12 years ago.
Screenshot of broken GUI - Modern theme

Download all attachments as: .zip

Change History (15)

Changed 12 years ago by SF/wooshell

Attachment: scummvm.jpg added

Screenshot of broken GUI

Changed 12 years ago by SF/wooshell

Attachment: scummvm2.jpg added

Screenshot of broken GUI - Modern theme

comment:1 Changed 12 years ago by SF/wooshell

Modern theme looks equally broken.. the graphics are fine, but fonts aren't rendered correctly.
Starting a game from the command line allows me to play fine, but the F5 menus don't work either.
File Added: scummvm2.jpg

comment:2 Changed 12 years ago by eriktorbjorn

Did that happen in ScummVM 0.10 as well, or is it a regression?

comment:3 Changed 12 years ago by SF/wooshell

Is definitely a regression. ScummVM 0.10.0 was perfectly usable (else I wouldn't have submitted the package those days). Nothing in my build environment has been changed since then.

comment:4 Changed 12 years ago by eriktorbjorn

Unfortunately, I can't even begin to guess what's wrong. It would be helpful if you could narrow down when between 0.10 and 0.11 the regression happened.

comment:5 Changed 12 years ago by SF/wooshell

I finally found out (after getting a few suggestions on #scummvm) that the issue comes from the configure script no longer detecting my machine as big-endian. I wouldn't have thought that this misconfiguration could manifest in this way, and still allow me to test-play MI1 without problems. Weird.

comment:6 Changed 11 years ago by jvprat

The problem seems to be that the behaviour of Solaris' grep is undefined when the input file contains binary data. Based on wooshell's suggestion, this could be a possible fix (supposing "strings" is installed on all build environments):

--- configure (revision 30613)
+++ configure (working copy)
@@ -899,7 +899,7 @@
int main() { _ascii (); _ebcdic (); return 0; }
EOF
$CXX $CXXFLAGS -c -o tmp_endianness_check.o tmp_endianness_check.cpp
-if grep BIGenDianSyS tmp_endianness_check.o >/dev/null; then
+if strings tmp_endianness_check.o | grep BIGenDianSyS >/dev/null; then
_endian=big
else
_endian=little

comment:7 Changed 11 years ago by sev-

Owner: set to jvprat

comment:8 Changed 11 years ago by sev-

Yesm strings is a standard POSIX utility, so this fix is OK.

Please, backport it to the branch too

comment:9 Changed 11 years ago by jvprat

Done. wooshell, let us know if you still have to do some manual modifications.

comment:10 Changed 11 years ago by jvprat

Resolution: fixed
Status: newclosed

comment:11 Changed 11 years ago by SF/wooshell

No more manual changes needed for this issue.
I would however be glad if a fix for #1523129 would also make it into the .1 release... this would mean I could finally build my release packages without any manual intervention. ;-)

comment:12 Changed 8 months ago by digitall

Component: --Unset--Ports

comment:13 Changed 8 months ago by digitall

Component: PortsPort: Solaris
Note: See TracTickets for help on using tickets.