Opened 12 years ago

Closed 12 years ago

#3545 closed defect (fixed)

ITE: Crash when using Eeah with Eeah

Reported by: SF/wikipedian Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM 0.9.1 (Jul 6 2007 05:02:12)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2 FluidSynth

OS: Kubuntu Linux

I'm using the German "Bestseller Games" version of Inherit the Earth (CD-ROM version with talkie).

How to reproduce:

Start the game. Press ESC to skip the intro. Select "Use Eeah with Eeah". The game will crash immediately. The same happens if you use Ook with Ook, also if you do it outside of the tent.

This is the console output:

Looking for ite
Trying to start game 'Inherit the Earth: Quest for the Orb'
WARNING: Frame List ID = 0 for actor index 177!
WARNING: Frame List ID = 0 for actor index 178!
WARNING: Frame List ID = 0 for actor index 179!
WARNING: Adlib: Unknown control change message 116 (0)!
WARNING: Adlib: Unknown control change message 116 (0)!
WARNING: Adlib: Unknown control change message 116 (0)!
WARNING: Adlib: Unknown control change message 116 (4)!
Script::sfScriptDoAction wrong object type 0x0!

Ticket imported from: #1861863. Ticket imported from: bugs/3545.

Change History (9)

comment:1 by SF/wikipedian, 12 years ago

Summary: Crash when using Eeah with EeahITE: Crash when using Eeah with Eeah

comment:2 by bluegr, 12 years ago

Owner: set to bluegr

comment:3 by bluegr, 12 years ago

This seems to be occurring only with the German version... performing this weird action in the English version works correctly. It is a bug with the scripts of the game itself. Have you tried installing the latest patches for the game from this page?
http://www.wyrmkeep.com/ite/update.html

comment:4 by bluegr, 12 years ago

I just noticed that you're running ScummVM version 0.9.1 which is a VERY old version, loads of things have changed since then. Please, download the latest SVN version from the downloads page:
http://scummvm.sourceforge.net/downloads/scummvmwin32.exe
and try it with this one, the issue should no longer be happening (at least I can't reproduce it with the latest SVN version).

Please reply if you're still having this issue with the latest SVN version

comment:5 by SF/wikipedian, 12 years ago

I just updated to ScummVM 0.10.0 (in Kubuntu Linux), and the problem still occurs. I haven't yet tested the SVN version. Also, I haven't yet had time to install the ITE updates.

comment:6 by SF/wikipedian, 12 years ago

I think I cannot install the ITE updates from http://www.wyrmkeep.com/ite/update.html (it says it cannot find ITE in the path I supplied), maybe they're for the English version only.

By the way, I ran ITE in dosbox. When I use Eeah with Eeah, it prints the error message "ID Error: doAction" to the dosbox console (so it is in fact an ITE bug), however the game doesn't crash.

comment:7 by sev-, 12 years ago

I just checked this bug.

I can easily reproduce it with any ITE version, including latest ones from Wyrmkeep.

It crashes when I try to use 'Eeah with Eeah' and 'Okk with Okk'. Sometimes it does not crash because actors start walking, so it is easier to reproduce it in the markeplace. Make sure that cursor will remain over the character.

Crash message is "Script::sfScriptDoAction wrong object type 0x0!"

comment:8 by bluegr, 12 years ago

Resolution: fixed
Status: newclosed

comment:9 by bluegr, 12 years ago

Fixed in the latest SVN and 0.11.0pre

Closing

Note: See TracTickets for help on using tickets.