Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#3536 closed defect (fixed)

FOTAQ: Jetty: "sign" at wrong position

Reported by: SF/clemty Owned by: cyxx
Priority: low Component: Engine: Queen
Keywords: original Cc:
Game: Flight of the Amazon Queen

Description

FOTAQ talkie, Win32, Dec 24

At the dock there is a sign telling you that the ferryman is fishing. However the hotspot somehow becomes shifted to the right later in the game (visible when executing "areas" in the debugger)

Not sure if this is a ScummVM or a FOTAQ script problem.

Ticket imported from: #1858081. Ticket imported from: bugs/3536.

Attachments (4)

queen.s22 (12.1 KB ) - added by SF/clemty 12 years ago.
"look at sign" - incorrect behavior
queen.s27 (12.3 KB ) - added by SF/clemty 12 years ago.
"look at sign" - correct behavior, before the ferryman takes you across
queen.s14 (12.1 KB ) - added by digitall 9 years ago.
Latest ScummVM savegame to demonstrate bug
_AQ_SAVE.7 (24.0 KB ) - added by digitall 9 years ago.
Original Engine savegame demonstrating same bug

Download all attachments as: .zip

Change History (14)

by SF/clemty, 12 years ago

Attachment: queen.s22 added

"look at sign" - incorrect behavior

by SF/clemty, 12 years ago

Attachment: queen.s27 added

"look at sign" - correct behavior, before the ferryman takes you across

comment:1 by SF/clemty, 12 years ago

File Added: queen.s27

comment:2 by sev-, 11 years ago

What is the status of this item?

comment:3 by SF/clemty, 11 years ago

Just tried it again with the savegames I submitted back then and win32 SVN from Jan 08 2009 - it still happens if I use the savegame. To reproduce it without the savegame I'd need to play through most of the game, something I don't have time for right now. However I'd assume this bug still exists. (Feel free to lower its priority, doesn't seem to affect gameplay much)

comment:4 by digitall, 9 years ago

Component: Engine: Queen
Game: Flight of the Amazon Queen

comment:5 by digitall, 9 years ago

Just replicated with HEAD i.e.
ScummVM 1.2.0svn52422 (Aug 28 2010 13:14:58)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ RGB zLib FluidSynth
on Linux 2.4.34 x86_32

This occurs after retrieving the crystal skull from the island temple and escaping Floda, if you return to the Jetty.

Attaching latest ScummVM savegame.
Will play through in original interpreter to see if it occurs there.

by digitall, 9 years ago

Attachment: queen.s14 added

Latest ScummVM savegame to demonstrate bug

comment:6 by digitall, 9 years ago

This bug occurs in the original interpreter as well.
Attaching original engine savegame to demonstrate.

comment:7 by digitall, 9 years ago

Keywords: original added
Priority: normallow

by digitall, 9 years ago

Attachment: _AQ_SAVE.7 added

Original Engine savegame demonstrating same bug

comment:8 by cyxx, 9 years ago

Resolution: fixed
Status: newclosed

comment:9 by cyxx, 9 years ago

There is an off-by one error in the original script triggers. I added a fix with commit 536813c9aeb958da52438a70499752ddef853eef. We could also add some code to detect corrupted savegames, but since this is minor, I haven't bothered to do so.

comment:10 by cyxx, 9 years ago

Owner: set to cyxx
Note: See TracTickets for help on using tickets.