Opened 15 years ago

Closed 8 weeks ago

Last modified 6 weeks ago

#3533 closed defect (fixed)

SCUMM/HE: Freddi Fish 4 - Incorrect/Missing talk animation

Reported by: raziel- Owned by: BLooperZ
Priority: high Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Freddi Fish 4

Description (last modified by raziel-)

ScummVM 0.11.0svn (Dec 23 2007 20:03:48) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Right when Freddi and Luther reveal Mr. Big to the crowd there are some lines spoken by Freddi only, with Luther swimming right beside her.

Two scenes with three lines of speech, inbetween a shot from Mr. Big.

  1. Freddi says her first line with her lips moving

  2. She says her second line but with LUTHER's lips moving

  3. and the third line is coming out of nowhere (No lips moving whatsoever) (Scary :-))

Freddi Fish 4: The Case of the Hogfish Rustlers of Briny Gulch (English/Windows)

Amiga OS4 gcc version 4.0.2 (AmigaOS build 20051012)

Save Game from before the scenes attached (Click on the greenish shark in the middle to reveal Mr. Big)

Ticket imported from: #1857700. Ticket imported from: bugs/3533.

Attachments (5)

freddi4-win-Freddi4.sg0 (129 bytes ) - added by raziel- 2 years ago.
freddi4-win-Freddi4.sg9 (17.4 KB ) - added by raziel- 2 years ago.
freddi4-win-Freddi4.sg4 (30.7 KB ) - added by raziel- 10 months ago.
freddi4-win-us-Freddi4.sg1 (16.3 KB ) - added by Thunderforge 2 months ago.
scummvm-freddi4-win-us-00001.png (507.6 KB ) - added by Thunderforge 2 months ago.

Download all attachments as: .zip

Change History (22)

comment:1 by Kirben, 15 years ago

Owner: set to Kirben

comment:2 by fingolfin, 14 years ago

What is the status of this item?

comment:3 by raziel-, 14 years ago

ScummVM 0.13.0svn (Dec 4 2008 16:00:19) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Still there i'm afraid

comment:4 by fingolfin, 13 years ago

What is the status of this item?

comment:5 by Kirben, 13 years ago

Unchanged, the problem still occurs.

comment:6 by Kirben, 12 years ago

Seems similar to bug #2964972, and is related to AKOS animations.

comment:7 by raziel-, 4 years ago

Summary: HE FREDDI4: Luther posessed and ghost whisperingSCUMM: HE - FREDDI4 - Luther posessed and ghost whispering

comment:8 by raziel-, 2 years ago

Description: modified (diff)
Summary: SCUMM: HE - FREDDI4 - Luther posessed and ghost whisperingSCUMM/HE: Freddi Fish 4 - Incorrect talk animation

comment:9 by raziel-, 2 years ago

Summary: SCUMM/HE: Freddi Fish 4 - Incorrect talk animationSCUMM/HE: Freddi Fish 4 - Incorrect/Missing talk animation

ScummVM 2.2.0git (Jul 14 2020 07:49:50)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG cloud (servers, local)

Issue is still there.

After some more testing it seems that the final scene suffers from this issue in general.
Revealing the true Mr. Big still shows the original issue as described in OP.

Choosing any innocent character will trigger the issue as well, but only for Luther, since Freddi will only comment at the end of the animation (she will say something along the lines of "No he/she is not Mr. Big, but that was good thinking" to Luther).

Though, every time Luther says more than one line and both Luther and Freddi are shown side by side, Luther will be animated with moving lips only on his first line. All following lines will not trigger any mouth movement animation, just the idle animation of both the characters floating.

Version 0, edited 2 years ago by raziel- (next)

by raziel-, 2 years ago

Attachment: freddi4-win-Freddi4.sg0 added

by raziel-, 2 years ago

Attachment: freddi4-win-Freddi4.sg9 added

comment:10 by raziel-, 10 months ago

I just found another instance of the same bug in the same game (see save game .sg4)

In the animation where Freddie pulls the air pump out of Luther's mouth she says:

1 - Luther!
2 - This is an airpump.
3 - You should be more careful.

The third line is coming from the off as Freddie is not moving her lips.

Last edited 10 months ago by raziel- (previous) (diff)

by raziel-, 10 months ago

Attachment: freddi4-win-Freddi4.sg4 added

comment:11 by Thunderforge, 2 months ago

Still an issue in 2.6.0 using both the US and UK versions from Steam.

Reproduction Steps

  1. Load the attached freddi4-win-Freddi-us-Freddi4.sg1
  2. Click the red button
  3. Wait until the suspect lineup (you can just keep hitting Esc)
  4. Click the squids in the upper right

The sequence then is as follows:

  1. Luther says his first line with lipsync
  2. Luther says his second line with no lipsync
  3. The squid family says several lines with lipsync
  4. Freddi says her first line with lipsync
  5. Freddi says her second line, but Luther has the lipsync
    • If you turn on subtitles, they are yellow to show they do indeed belong to Freddi
  6. Luther says his final line with lipsync

It's also reproducible with some other characters, but the squid family's sequence shows the bug most obviously.

Last edited 2 months ago by Thunderforge (previous) (diff)

by Thunderforge, 2 months ago

Attachment: freddi4-win-us-Freddi4.sg1 added

by Thunderforge, 2 months ago

comment:12 by Thunderforge, 2 months ago

Priority: normalhigh

comment:13 by Thunderforge, 8 weeks ago

Owner: changed from Kirben to BLooperZ
Resolution: fixed
Status: newclosed

Fixed by PR #4138.

comment:14 by raziel-, 8 weeks ago

@Thunderforge

Do I need to create new items?
1) See comment 10, this is still broken.

2) Also, since the fix a new instance popped up.

From savegame 4, click the red button but do NOT ESCape your way to the suspect lineup, instead watch every scene.
There is one scene just before the lineup where Freddi is shown alone talking, but no lip movement.
That's a regression, didn't happen before the fix.

comment:15 by BLooperZ, 8 weeks ago

Thanks @raziel
could you please provide the text being said on the lines with the problem?
(to be able to find them when testing the fix)

Thanks again

comment:16 by raziel-, 8 weeks ago

I have to postpone the answer as I had to rush to work after finding the issue.

I don't have access to my setup.

It should be one of those lines where Freddie says that Mr. Big is right in this room, but I'm not sure.

It's definitely shortly before the player gets control back to reveal Mr. Big (Luther is already beside her but doesn't have any lines, wrongly to what I've written before regarding her being alone in the shot)

And comment 10 describes another problematic line in detail.

comment:17 by raziel-, 6 weeks ago

@BlooperZ

As i said, two problems still persist.

  1. is the one from comment 10

and

  1. is below

Just before the reveal (savegame in front of the red button)
1) Press the red button
2) Press ESC three times
3) You'll end up in the scene where the rustlers enter their makeshift prison and see the last Hogfish leave.
Let the scene play until Freddi and Luther get their closeup.
Freddi will say "He's right" "pointing" towards the screen and then a long monologue starts where she is already kind of "frozen" (no lip movement).
Her lines while frozen are:
When the rustlers caught Luther and me, he called Mr. Big to decide what to do.
I suspect he was already here when you all arrived and slipped in with the party.

Note: See TracTickets for help on using tickets.