Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#3530 closed defect (fixed)

GOB2: WINCE: Parts of menus randomly appear

Reported by: spookypeanut Owned by: SF/knakos
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

0.11.0svn, built Dec 18
Windows Mobile 5 on PocketLOOX N560
Gob2 English DOS CD

Throughout playing gob2 on wince, parts of menus I have previously used (sometimes the list of saved games, sometimes the inventory) seemingly randomly appear on screen. I have enclosed a saved game where the problem is consistently repeatable.

After loading the saved game, use right-click (mapped to a button) to bring up the inventory. Select the only item in the inventory, and when the window closes, a line from a previous menu ("underwater", the name of one of my saved games) will appear somewhere on screen.

Loading this save game on Linux, the bug does not appear.

Ticket imported from: #1856469. Ticket imported from: bugs/3530.

Attachments (2)

gob2cd.s13 (3.1 KB) - added by spookypeanut 11 years ago.
savegame at point with bug
gob2cd.s14 (3.0 KB) - added by spookypeanut 11 years ago.
savegame just before bug

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by spookypeanut

Attachment: gob2cd.s13 added

savegame at point with bug

Changed 11 years ago by spookypeanut

Attachment: gob2cd.s14 added

savegame just before bug

comment:1 Changed 11 years ago by spookypeanut

Have included a savegame just before, since that's what you guys usually ask for ;-)
Just use the key on the gate, sit through the cutscene and (for me at least) the problem reappears (tho the line of text has changed)
File Added: gob2cd.s14

comment:2 Changed 11 years ago by fingolfin

Owner: set to SF/knakos

comment:3 Changed 10 years ago by fingolfin

What is the status of this item?

comment:4 Changed 10 years ago by spookypeanut

As far as I know, the bug still exists. I haven't tried compiling for wince since the gmm etc, so my most recent version is 0.12.0. i'll try compiling today.

comment:5 Changed 10 years ago by SF/knakos

I'm tentatively closing this. I cannot load these savegames (it seems the format has changed?). I believe this was fixed by way of implementing the showMouse callback.
Feel free to re-open this if it persists in 1.0.0rc1.
Thanks for the report.

comment:6 Changed 10 years ago by SF/knakos

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.