Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3529 closed defect (fixed)

LURE:Crash at Prision.. savegame included.

Reported by: SF/djdiabolik Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM 0.11.0svn (Dec 21 2007 20:32:50)
Vesion/Language of games: Italian Floppy Version
Lure.dat Revision 29936
Platform: Win32 Played on Windows XP Pro SP2

Load the savegames... try to look at the prisioner on the left wall... the games goes on crash and i will return on Desktop of my XP.

i try to lauch this games from dos promt.. this is the result after crash:

Assertion failed: charIndex < numFontChars, file engines/lure/surface.cpp, line
321

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Thanks for suggestion.

Ticket imported from: #1856082. Ticket imported from: bugs/3529.

Attachments (3)

lure.003 (14.7 KB) - added by SF/djdiabolik 12 years ago.
debug.zip (19.6 KB) - added by SF/djdiabolik 12 years ago.
debug_new.zip (20.1 KB) - added by SF/djdiabolik 12 years ago.

Download all attachments as: .zip

Change History (17)

Changed 12 years ago by SF/djdiabolik

Attachment: lure.003 added

comment:1 Changed 12 years ago by SF/djdiabolik

Ops... the savegame :)
File Added: lure.003

comment:2 Changed 12 years ago by dreammaster

The problem seems to be that something is setting the Description Id of the prisoner (hotspot 412h) from the default 218 to an invalid value of 299. I've tested that saving and restoring doesn't corrupt the description, so it must be one of the actions you're doing prior to it. I've tried to go through all the standard steps up until that point, but haven't had any luck - I'd appreciate it if you can assist somewhat in tracking down exactly where the problem occurs.

What you can do is press Control-D to bring up the debug console and then type 'hotspot 412h'. This will give you the details of the prisoner. By default, it will have a descs = (218,0). You can then press Escape to return to the game. If you could keep re-entering the console and repeating that command (you can use the Up arrow to quickly bring back the last entered command), and see if you can determine exactly when the descs changes.

Another thing that would be useful is if you could run the game with the line:
scummvm --debuglevel=3 --debugflags=animations,scripts,hotspots,strings
lure > debug.txt

And play the game from the start to when the error occurs? If you could zip that up and upload it, it may also help me determine why the problem is occurring.

comment:3 Changed 12 years ago by dreammaster

Owner: set to dreammaster

comment:4 Changed 12 years ago by SF/djdiabolik

[quote]
Another thing that would be useful is if you could run the game with the
line:
scummvm --debuglevel=3 --debugflags=animations,scripts,hotspots,strings
lure > debug.txt
[/quote]
Ok.. i have not understand very good..... i try this solution :)

comment:5 Changed 12 years ago by dreammaster

Thanks. Just remember to play the game all the way from the beginning until the game crashes. Then zip and upload the resulting debug.txt

comment:6 Changed 12 years ago by SF/djdiabolik

Ok.. i have play the game now without upgrade my svn version and lure.dat revision....

comment:7 Changed 12 years ago by dreammaster

Thanks. Could you upload the resulting debug.txt file?

Changed 12 years ago by SF/djdiabolik

Attachment: debug.zip added

comment:8 Changed 12 years ago by SF/djdiabolik

I have found another way to find this crash:
1) Excape from my room and lock here the skorl
2) Take the knife on the barrel
3) Look at prisioner of the left wall and find a bug on it
4) Use the knife with bag
5) After it i try again to watch (press left button of mouse on it) the prisioner
I will back to my Desktop of XP SP2. I have Saved the Debug file :)
File Added: debug.zip

comment:9 Changed 12 years ago by SF/djdiabolik

I'm try now to upgrade my svn version and obtain the eventual new lure.dat......

Changed 12 years ago by SF/djdiabolik

Attachment: debug_new.zip added

comment:10 Changed 12 years ago by SF/djdiabolik

This is a new Dedug.txt.... i have make it with same operation but with this latest snv:
- ScummVN svn 0.11.0 (Dec 23 2007 22:35:20)
- Lure.dat revion 29947

At same point same crash..........
File Added: debug_new.zip

comment:11 Changed 12 years ago by dreammaster

Resolution: fixed
Status: newclosed

comment:12 Changed 12 years ago by dreammaster

Thanks, I was able to identify the problem - it was a bug with the original game that the look description was unterminated. The Lure engine now joins the ranks of game engines that can claim to work around bugs in the original game. :)

comment:13 Changed 12 years ago by SF/djdiabolik

you can fix this problems ?

comment:14 Changed 12 years ago by dreammaster

Yes, it's fixed.

Note: See TracTickets for help on using tickets.