Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3525 closed defect (fixed)

FT: Crash/hangup at Corley Motor factory

Reported by: SF/djdiabolik Owned by: cyxx
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM version: 0.11.0svn (Dec 19 2007 12:56:45)
Language of Game: Italian CD Version
Platform: Win32 played on Windows XP Sp2

Detail of Crash:
1) Please load the savegame i have attach here
2) At this point go to on back of the factory of Corley Motor
3) At this point the game goes on crash:
- When i try to SaveGame here
- When i try to kick the wall
- When i try to look some object here

In most case i will back on desktop of my XP or i can use the task manager for close the ScummVM for back on my Desktop.....

I can aspect for your support.. thanks.

Ticket imported from: #1854550. Ticket imported from: bugs/3525.

Attachments (5)

ft-it.s11 (21.0 KB) - added by SF/djdiabolik 12 years ago.
Use this savegame and read my istruction for found a bug....thanks
debug_1.txt (7.4 KB) - added by SF/djdiabolik 11 years ago.
ft-it.s10 (27.3 KB) - added by SF/djdiabolik 11 years ago.
debug_2.txt (32.2 KB) - added by SF/djdiabolik 11 years ago.
1854550.diff (915 bytes) - added by cyxx 11 years ago.

Download all attachments as: .zip

Change History (44)

Changed 12 years ago by SF/djdiabolik

Attachment: ft-it.s11 added

Use this savegame and read my istruction for found a bug....thanks

comment:1 Changed 12 years ago by fingolfin

Summary: Crash at this SaveGame..FT: Crash in italian version at Corley Motor factory

comment:2 Changed 12 years ago by SF/djdiabolik

Thanks @all for change the title of topic......

comment:3 Changed 12 years ago by SF/djdiabolik

Hi boys...i need an info... i can continue to play the storyline with this problems/bug ?? or I have to must make something in this rooms for continue the game ?

comment:4 Changed 12 years ago by SF/djdiabolik

Please don't spoiler me the solution.. aswer only yes or not :)

comment:5 Changed 11 years ago by SF/djdiabolik

Nothing for this Bug ???

comment:6 Changed 11 years ago by SF/djdiabolik

Priority: normalblocker

Changed 11 years ago by SF/djdiabolik

Attachment: debug_1.txt added

comment:7 Changed 11 years ago by SF/djdiabolik

I have run this game with the Debug Command Line.
When i try to load this savegame the game goes in crash and i will back on desktop of my XP....

File Added: debug_1.txt

comment:8 Changed 11 years ago by sev-

Please, DO NOT PLAY with priorities.

comment:9 Changed 11 years ago by sev-

Priority: blockerlow

Changed 11 years ago by SF/djdiabolik

Attachment: ft-it.s10 added

comment:10 Changed 11 years ago by SF/djdiabolik

I try to reach this point from a previous savegames... at the load of state don't goes on crash but goes on crash at same point and in same mode.... find a solution please :(
File Added: ft-it.s10

comment:11 Changed 11 years ago by SF/djdiabolik

Priority: lowblocker

Changed 11 years ago by SF/djdiabolik

Attachment: debug_2.txt added

comment:12 Changed 11 years ago by SF/djdiabolik

This is the Debug text file make when using the ft-it.s10
File Added: debug_2.txt

comment:13 Changed 11 years ago by fingolfin

Changing priority back again to 3. Please do not touch it.

Sorry, we can't work miracles. None of us has the italian FT version, and so we may not be able to reproduce the issue at all. Also, it's christmas, and even us ScummVM developers have a family etc. and may not devote as much time to fixing bugs as you may wish for :)

Those debug output files are of no use, I am afraid. They do not contain any information about whatever causes ScummVM to crash/lockup. One probably has to run a real debugger on it to find out more.

comment:14 Changed 11 years ago by fingolfin

Priority: blockerlow

comment:15 Changed 11 years ago by SF/djdiabolik

ok but i can continue to play the games with this problems ??? or in this point i need to do sometime for continue the story ?

comment:16 Changed 11 years ago by sev-

Owner: set to sev-
Status: newpending

comment:17 Changed 11 years ago by sev-

Please, provide md5s and file sizes of follwoing files:

ft.la1
monster.sou

You can get Windows md5 utility here: http://www.pc-tools.net/win32/md5sums/

I can not reproduce it here.

comment:18 Changed 11 years ago by SF/djdiabolik

Status: pendingnew

comment:19 Changed 11 years ago by SF/djdiabolik

Md5 of FT.LA1... you can view a snapshot of my dosprompt here:
http://img175.imageshack.us/img175/1858/ftla1dv3.jpg

The FileSize of FT.LA1 it's 148MB (155.672.400 byte)

Md5 of Monster.sou here:
http://img175.imageshack.us/img175/8218/monstersouct6.jpg

The Filesize of MONSTER.SOU it's 94.7MB (99.332.920 Byte)

i don't have understand.... if you go at rear of corley motors factory and try to kick the wall you don't my same bug ???

comment:20 Changed 11 years ago by sev-

The md5s are same.

It works well under FreeBSD, Ben kicks the Wall.

Though I tested under Windows XP and got a hang. Weird.

comment:21 Changed 11 years ago by sev-

OK, further testing showed that this is not version-specific. Looks like a regression.

Bootparam 800, leave discussion with Mo (last option), leave the room, then go behind the factory and kick the wall. It will hang up.

This is release critical, raising priority.

Travis, if you can take a look into it, please do, otherwise unassign.

comment:22 Changed 11 years ago by sev-

Owner: changed from sev- to Kirben
Priority: lowblocker
Summary: FT: Crash in italian version at Corley Motor factoryFT: Crash/hangup at Corley Motor factory

comment:23 Changed 11 years ago by Kirben

This looks like a regression in iMuse digital code, the last debug output is:
(61:2000:0xE231): Script 2000, offset 0xe231: [74] o6_startSound()
(61:2000:0xE231): pop 407
(61:2000:0xE231): startSfx(407)
(61:2000:0xE231): IMuseDigital::startSound(407)
(61:2000:0xE231): IMuseDigital::allocSlot(): All slots are full
(61:2000:0xE231): IMuseDigital::allocSlot(): Removed sound 409 from track 2
(61:2000:0xE231): Locking mutex IMuseDigital::flushTracks()
(61:2000:0xE231): flushTracks()
(61:2000:0xE231): Unlocking mutex IMuseDigital::flushTracks()

The last three lines are endlessly repeated.

Compared to the debug output in ScummVM 0.10.0:
(61:2000:0xE231): Script 2000, offset 0xe231: [74] o6_startSound()
(61:2000:0xE231): pop 407
(61:2000:0xE231): startSfx(407)
(61:2000:0xE231): IMuseDigital::startSound(407)
(61:2000:0xE231): ensureResourceLoaded(Sound,407)
(61:2000:0xE231): getResourceAddress(Sound,407) == 020A700C
(61:2000:0xE232): Script 2000, offset 0xe232: [1] o6_pushWord()
(61:2000:0xE234): push 12
(61:2000:0xE235): Script 2000, offset 0xe235: [1] o6_pushWord()
(61:2000:0xE237): push 407
(61:2000:0xE238): Script 2000, offset 0xe238: [1] o6_pushWord()
(61:2000:0xE23A): push 1792
(61:2000:0xE23B): Script 2000, offset 0xe23b: [1] o6_pushWord()
(61:2000:0xE23D): push 30
(61:2000:0xE23E): Script 2000, offset 0xe23e: [1] o6_pushWord()
(61:2000:0xE240): push 4
(61:2000:0xE241): Script 2000, offset 0xe241: [AC] o6_soundKludge()
(61:2000:0xE241): pop 4
(61:2000:0xE241): pop 30
(61:2000:0xE241): pop 1792
(61:2000:0xE241): pop 407
(61:2000:0xE241): pop 12
(61:2000:0xE241): Locking mutex IMuseDigital::setPan()
(61:2000:0xE241): IMuseDigital::setPan(407, 30)
(61:2000:0xE241): Unlocking mutex IMuseDigital::setPan()

comment:24 Changed 11 years ago by Kirben

Owner: Kirben deleted

comment:25 Changed 11 years ago by sev-

Owner: set to aquadran

comment:26 Changed 11 years ago by Kirben

Owner: changed from aquadran to cyxx

comment:27 Changed 11 years ago by Kirben

The lockup when kicking the wall behind the factory, is caused by iMuse digital changes made by cyx in revision 29705.

comment:28 Changed 11 years ago by cyxx

My changes have been reverted/removed since revision 30111.

But there's a problem with current SVN code, in IMuseDigital::allocSlot(), there shouldn't be any references to _mutex (the _mutex.unlock() and _mutex.lock() lines should be removed).

comment:29 Changed 11 years ago by SF/djdiabolik

I don't have understand nothing how i can do for pass this bug, now i try to install the today SVN :) Thanks for all your support.

comment:30 Changed 11 years ago by cyxx

Ignore my previous statement, looks like allocSlot() is always called with the _mutex locked on, so there should be no problem.

But, I am unable to reproduce the issue. Kirben, are those debug traces made with a recent SVN snapshot ? (I fail to see how/why there is an infinite loop on flushTracks() with current code).

comment:31 Changed 11 years ago by sev-

Yes, I tested it with yesterday's SVN, and I always have the hang, but only with daily build under Win32. With my own builds under FreeBSD the game behaves as usual.

Changed 11 years ago by cyxx

Attachment: 1854550.diff added

comment:32 Changed 11 years ago by cyxx

ah indeed, the problem is in the branch (and easily reproducable in fast mode).
attached a patch, which fixes the problem for me (race between allocSlot and flushTracks while loop)
File Added: 1854550.diff

comment:33 Changed 11 years ago by SF/djdiabolik

OK... how i can use this .diff file ?

I have the ScummVM 0.11.0pre (Jan 3 2008 20:57:32)

comment:34 Changed 11 years ago by fingolfin

That patch looks good, cyx (I fixed the same bug in the trunk with my recent iMuse Digital bug fix patch, but I didn't want to push it to the branch (yet) as it may cause regressions, and we are in a freeze, after all).

djdiabolik: If you compile ScummVM from source, you can apply the patch to the source then recompile. If you don't understand what that means: Don't worry at all, just wait for us to tell you that it's fixed ;)

comment:35 Changed 11 years ago by fingolfin

I commited this and another patch to SVN.

DjDiabolik, please try with the next daily build.

comment:36 Changed 11 years ago by SF/djdiabolik

This Daily Build 0.11.0pre (Jan 4 2008 10:38:44) or the daily or tomorrow ?

comment:37 Changed 11 years ago by SF/djdiabolik

I have try with the daily build already said........ when i try to kick the walls............... NO CRASH!!! it's all ok.. Thanks boys, now i'm back to play this game.

comment:38 Changed 11 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:39 Changed 11 years ago by SF/djdiabolik

I have finished this fantastic adventure... thanks for all your support.

Note: See TracTickets for help on using tickets.