Opened 12 years ago

Closed 12 years ago

#3522 closed defect (fixed)

LURE: Game crashes/exits using Right-Click + "Status"

Reported by: SF/helh Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

Hi,

Lure crashes whenever I try to bring up the status of my character through "right click" + "Status". I get the following error:

-
Assertion failed: charIndex < numFontChars, file engines/lure/surface.cpp, line
321

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
-

Windows XP SP2
ScummVM 0.11.0 SVN Dec 18 2007 20:12:04 binary from website
Lure English
most recent lure.dat file, just downloaded a few minutes ago to check if that was the problem

Ticket imported from: #1853542. Ticket imported from: bugs/3522.

Change History (2)

comment:1 by dreammaster, 12 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

comment:2 by dreammaster, 12 years ago

Looks like the assertion I added in the previous fontWidth fix paid off - the wordWrap method wasn't correctly handling newline \n characters in text to word wrap. This was likely the cause of the problems someone, Chrillith I think, was having with the status screen on the PDA.

Note: See TracTickets for help on using tickets.