Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3504 closed defect

SQ1 AGI: Keypad Sequence Breaks

Reported by: SF/johndmes Owned by:
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: Space Quest 1

Description

ScummVM version: 0.11.0.0
Game: Space Quest 1 EGA (original AGI version 1.0)

Late in the game, the player is required to use a virtual keyboard to enter a code into a panel. The interface used is a onscreen numeric keypad, which the player uses to enter the code.

The keypad is used by manipulating a onscreen arrow using the directional keys, and entering each digit using F6.

In ScummVM 0.11.0.0, the arrow can be manipulated and the keypad buttons will flash with each press of F6, but no digits are entered, rendering the sequence unplayable and the game unfinishable. Attached find a save file at the appropriate place in the game; to start the sequence, walk up the stairs and type "LOOK AT PANEL". The numbers that have to be entered to complete the sequence successfully are 6858.

Ticket imported from: #1849023. Ticket imported from: bugs/3504.

Attachments (1)

sq1.008 (1.3 KB ) - added by SF/johndmes 12 years ago.
Save file for SQ1 EGA generated by ScummVM 0.11.0.0

Download all attachments as: .zip

Change History (10)

by SF/johndmes, 12 years ago

Attachment: sq1.008 added

Save file for SQ1 EGA generated by ScummVM 0.11.0.0

comment:1 by bluegr, 12 years ago

Just tried your saved game, indeed, if a button is pressed the corresponding digit is not shown on screen, but the number is entered correctly. i.e. you can press keys 6858 and then Enter, and the sequence will start, so the game is completable

I'm not sure if a number is supposed to be shown when a button is pressed, is that how the original behaved?

comment:2 by SF/johndmes, 12 years ago

Hmm - Just retried it on my own system, the numbers do nto display and pressing ENTER does not allow the sequence to complete. Strange.

In the original Sierra AGI version the numbers do indeed display as you enter them (verified on PC original SQ1 that belongs to a friend).

The version of Space Quest 1 that I am using to thest is the original release. It was rerelased later with redone graphics as "Space Quest 1 VGA" - though I don't think that one uses the AGI interpeter (not sure on that).

comment:3 by bluegr, 12 years ago

Note: the game version that the user has is "Space Quest 1: The Sarien Encounter (2.2 1987-05-07
5.25"/3.5"/DOS/English)", under XP SP2 (taken from bug report #1849017)

The newer VGA version uses the SCI interpreter and is not supported by ScummVM.

As I mentioned, I can press the buttons under ScummVM and they work correctly (using the same version of SQ1), even if the number pressed is not shown. Thanks for verifying that this is indeed a bug with ScummVM itself and not with the original game, seems it's a screen effect that is not implemented correctly.

comment:4 by bluegr, 12 years ago

Can you please provide a saved game at the same spot, created by the original game interpreter and/or nagi?

comment:5 by bluegr, 12 years ago

I just checked the script for the console screen. It's logic script 65, and the only output it gives to the screen is the dots, the "Invalid Code" message and the "Warning" message when you get the sequence right, so it's not possible that you're seeing numbers on the terminal's screen with the original interpreter, when you press the corresponding buttons (unless you saw the numbers in the VGA version, which is a totally different game).

In this screen, you are supposed to:
- move the RED CURSOR with the arrows
- press buttons "6", "8", "5", "8" using the F6 key
- press the "enter" button by pressing the F6 key again

You can't click on the buttons with the game's normal "white" cursor, and you can't press the "enter" key on your keyboard to press a button (note that this behavior is normal, as the original game did not have a mouse cursor).

Please, try performing the steps above and reply if that worked for you

comment:6 by fingolfin, 12 years ago

Status: newpending

comment:7 by fingolfin, 12 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:8 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:9 by SF/sf-robot, 12 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.