Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#350 closed defect (invalid)

FOA: Crash during intro with sound (PocketScumm)

Reported by: SF/variable53 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Hi all,

I got an iPAQ3870 and I'm runnin Indy 4 on a 128MB
Sandisk SD-Card. I also use the monster.so3 file,
created by the .SOU to MP3 conversion utility which
can be found on
http://arisme.free.fr/PocketScumm/index.html

If I use this speech file the game crashes without any
further notice (if I use the original ScummVM release
0.2.0) and ScummVM simply quits. If I use arisme's
release ScummVM quits with this error:

Error: (EXCD) Not found in 0... illegal block len -
1768515946!

BUT the music plays on and on and......

This problem always occurs at the exact same moment
during the intro (when indy wants to show "Smith" the
key he just found). When I skip the intro the game runs
normal. If I use an older version of ScummVM which
does not support the newly impemented mp3 to so3
soundfiles, everything works just fine.
If anyone got an idea what I can do please post it here.

thx
VaRiAblE

Ticket imported from: #581955. Ticket imported from: bugs/350.

Change History (7)

comment:1 by fingolfin, 17 years ago

Summary: Indy4 crashes during intro with soundFOA: Crash during intro with sound (PocketScumm)

comment:2 by fingolfin, 17 years ago

Sounds like this might be a PocketScumm crash. I have no
version of FOA with .SOU data, hence I can't test.

Will tell arisme to have a look at this.

comment:3 by SF/arisme, 17 years ago

as I specified in my previous mail, can you recheck with the
latest build available at
http://arisme.free.fr/PocketScumm/daily ?

if you can reproduce it I'll investigate the issue which looks
like an mp3 conversion problem - and put the ScummVM
error logs back in my next build as it's useful to locate some
problems :)

comment:4 by SF/arisme, 17 years ago

ok, looks like I need to investigate this.

Can you give me the size (and possible checksum ? you can
download an md5sum for Windows from http://www.acme-
ids.org/downloads/windows/others/md5sum/ if you need one)
of the monster.sou and monster.so3 files ?

comment:5 by SF/arisme, 17 years ago

problem solved "the Windows way" (reinstall from scratch :)) -
topic can be closed !

comment:6 by fingolfin, 17 years ago

Status: newclosed

comment:7 by Kirben, 10 years ago

Owner: set to fingolfin
Resolution: invalid
Note: See TracTickets for help on using tickets.