Opened 15 years ago

Closed 4 months ago

#3493 closed defect (fixed)

SCUMM: Dig - Rat Trap Puzzle Error

Reported by: SF/mthreepwood Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: The Dig

Description

Win32 (WinXP SP2) 0.11.0svn (December 9, 2007) The Dig (Windows/English)

At the rat trap puzzle, after I set it up (the dowel, hook, cage, and rod), I accidentally hit the hook. It duplicated the image of the hook, and set the trap, trapping an invisible rat. Low even says his lines that the rat is trapped. I am still able to put the bracelet on the rat and let him loose (ie it does not hinder the game). Once released, the duplicate hook image disappears.

Screenshot attached, no saved game yet (sorry, didn't save before, will upload one later).

Ticket imported from: #1847454. Ticket imported from: bugs/3493.

Attachments (3)

RatTrapError.PNG (177.8 KB ) - added by SF/mthreepwood 15 years ago.
Screenshot
dig.s07 (43.0 KB ) - added by SF/mthreepwood 8 years ago.
dig.s08 (42.6 KB ) - added by SF/mthreepwood 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by fingolfin, 15 years ago

This sounds like a script bug might be at hand...

by SF/mthreepwood, 15 years ago

Attachment: RatTrapError.PNG added

Screenshot

comment:2 by SF/mthreepwood, 15 years ago

Aye, that was my guess too.

Er... *now* here's the screenshot.

Also, I have a saved game, but I can't reproduce it exactly. Still, it did occur. File Added: RatTrapError.PNG

comment:3 by sev-, 14 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:4 by sev-, 14 years ago

Priority: normalhigh

comment:5 by SF/mthreepwood, 14 years ago

I'll make sure I test The Dig and make more saves. ;)

comment:6 by sev-, 10 years ago

Priority: highnormal

by SF/mthreepwood, 8 years ago

Attachment: dig.s07 added

comment:7 by SF/mthreepwood, 8 years ago

It took seven years, but I finally reproduced the bug.

dig.s07 is right before it happened, dig.s08 is right after. The glitch is still present in dig.s08.

From save 7, I had dug the tunnel to make it wider, went in, came out, and walked to the right without the rat being there. The trap animation just triggered and the glitch appeared.

comment:8 by raziel-, 2 years ago

Summary: DIG: Rat Trap Puzzle ErrorSCUMM: Dig - Rat Trap Puzzle Error

comment:9 by AndywinXp, 4 months ago

I can't reproduce this anymore, can anyone confirm it?

comment:10 by AndywinXp, 4 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

It seems nobody else was able to replicate this, so this might have been fixed as a side effect of some SCUMM v7 accuracy fixes. Closing this!

Note: See TracTickets for help on using tickets.