Opened 11 years ago

Closed 11 years ago

#3471 closed defect (fixed)

LURE: Invalid ASCII character passed

Reported by: raziel- Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM 0.11.0svn (Nov 30 2007 18:10:41)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Right at the beginning of the game i get a
Invalid ascii character passed for display '194'!
when i move the cursor over the Skorrl, that enters
my cell. Game quits.

Lure of the Temptress (English/Floppy)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1841875. Ticket imported from: bugs/3471.

Change History (5)

comment:1 Changed 11 years ago by raziel-

Addendum:

I get
Invalid ascii character passed for display '187'!
when i leave the Skorrl alone and instead move the cursor
over the door he closed after he left

Needless to say, i'm stuck :-)

comment:2 Changed 11 years ago by dreammaster

Owner: set to dreammaster

comment:3 Changed 11 years ago by dreammaster

I've identified and fixed an endian bug in the string decoder which was likely the cause of the error. If you could test either tomorrow's daily build or your own copy if you're building it yourself, and let me know if it fixes the problem.

comment:4 Changed 11 years ago by raziel-

Fixed in revision 29674.

Thanks a lot dreammaster

comment:5 Changed 11 years ago by dreammaster

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.