Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3466 closed defect (duplicate)

ZAK FM-TOWNS: Mars button crash

Reported by: SF/cfdavid Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM 0.10.0 Win32
Zak McKracken (FM-Towns, English)

Using attached save file, push Mars building door button with either Melissa or Leslie. Click is heard, then ScummVM console appears with message:
ERROR: (27:205:0x12944): class 0 is out of bounds (1,32)

Ticket imported from: #1840729. Ticket imported from: bugs/3466.

Attachments (1)

zak-fm.s04 (13.1 KB ) - added by SF/cfdavid 12 years ago.
Crash save file.

Download all attachments as: .zip

Change History (9)

by SF/cfdavid, 12 years ago

Attachment: zak-fm.s04 added

Crash save file.

comment:1 by Kirben, 12 years ago

Summary: Mars button crashZAK FM-TOWNS: Mars button crash

comment:2 by SF/cfdavid, 12 years ago

Also occurs with latest SVN build.

comment:3 by bluegr, 12 years ago

Status: newpending

comment:4 by bluegr, 12 years ago

This has been reported again in #1668393 - "ZAK FM-TOWNS: crash when entering the Hostel building"
http://sourceforge.net/tracker/index.php?func=detail&aid=1668393&group_id=37116&atid=418820

Quoting fingolfin from that bug report:
"The save seems to be broken. It executes a script at a wrong offset. A
typical problem that would occur when using a savestate made by a different
version of a game. Not sure how this could have happened here, unless maybe
the save was at some point used in a fan made translation of Zak FM-TOWNS?"

comment:5 by SF/sf-robot, 12 years ago

Status: pendingclosed

comment:6 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:7 by Kirben, 10 years ago

Closing as duplicate of #1668393.

comment:8 by Kirben, 10 years ago

Owner: set to Kirben
Resolution: duplicate
Note: See TracTickets for help on using tickets.