Opened 11 years ago

Last modified 7 years ago

#3454 new defect

COMI: Part 5: Clickable sky behaves strangely

Reported by: spookypeanut Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Once rid of the mime from the carnival side-show thingy, going through the gate reveals a triangle of sky in the top left. This sky can be highlighted like a useable object, but seems to have no name.

This is odd in itself, but when trying to use an object on it, every object seems to revert to the name "heavy fake pie" (which Guybrush no longer has) in the sense that at the bottom of the screen it says "give heavy fake pie to" (with no object name at the end).

Strikes me as a script bug (tho I have no way of checking in the original interpreter, unfortunately), and a minor one at that, so you may want to just ignore it. Thought I should report it tho :-)

Ticket imported from: #1834818. Ticket imported from: bugs/3454.

Attachments (5)

comi.s24 (98.2 KB) - added by spookypeanut 11 years ago.
save game with bug evident
comi.s30 (97.0 KB) - added by spookypeanut 11 years ago.
save game before using heavy pie pan
comi.s05 (76.7 KB) - added by spookypeanut 11 years ago.
save game from start of part 5
comi.md5 (39.7 KB) - added by spookypeanut 9 years ago.
Result of "find | xargs md5sum"
comi.s70 (77.4 KB) - added by fingolfin 9 years ago.
save game before creating "fake pie pan"

Download all attachments as: .zip

Change History (32)

Changed 11 years ago by spookypeanut

Attachment: comi.s24 added

save game with bug evident

comment:1 Changed 11 years ago by sev-

Owner: set to fingolfin

comment:2 Changed 11 years ago by sev-

Max, can you confirm this or assign to one who can?

comment:3 Changed 11 years ago by cyxx

Tested with the original interpreter (with a savegame near the end of part 5) and nothing like this.

With your savegame, there's a floating object without the untouchable class, so it's "normal" that you could interact with it. Do you have a savegame made before the glitch occurs ? It would be easier that way to "catch" which script setup/modified this object.

comment:4 Changed 11 years ago by fingolfin

I am currently on a conference and can't look into this. But maybe cyx can ;)

comment:5 Changed 11 years ago by fingolfin

Owner: changed from fingolfin to cyxx

comment:6 Changed 11 years ago by cyxx

...maybe but with another savegame.

spookypeanut, can you attach one made before the glitch occurs ?

Changed 11 years ago by spookypeanut

Attachment: comi.s30 added

save game before using heavy pie pan

comment:7 Changed 11 years ago by spookypeanut

Sorry for the delay, away for the weekend. Have attached a savegame from just before using the heavy pie pan. If you need one from another point, let me know.
File Added: comi.s30

comment:8 Changed 11 years ago by fingolfin

Re-loading the room (by typing "room 86" in the debugger) makes this go away.

The object id of the "sky triangle" seems to be 119. The string "heavy fake pie" appears because var300 points to object 452, which is the "heavy fake pie". Script 39, which is the one responsible for generating the "give XYZ to ABC" string uses that var to generate its text.
But it's not clear to me why the sky triangle got clickable in the first place...

Note that in your "save before", the bug is already present -- you can already see the sky triangle if you move a bit to the left, and it already shows the buggy behavior.

If, however, I go to a save game of mine (just before being transformed to a kid), I don't get this behavior. So, something is broken in your savegame. The only question now is: Is this a one-time goof, or is it reproducible?

comment:9 Changed 11 years ago by fingolfin

Owner: cyxx deleted

comment:10 Changed 11 years ago by spookypeanut

Hmm, interesting. I got to the earlier of the two saved games by going back to before being transformed to a kid, and playing through a bit further, so it is reproducible in that sense. I'll try and investigate in more detail at some point.

comment:11 Changed 11 years ago by fingolfin

Maybe you could then attach the savegame you used from before being transformed? This way, I could at least try to analyze what goes wrong.

Changed 11 years ago by spookypeanut

Attachment: comi.s05 added

save game from start of part 5

comment:12 Changed 11 years ago by spookypeanut

Here you go: let me know if I can try anything else.
File Added: comi.s05

comment:13 Changed 10 years ago by sev-

Owner: set to fingolfin

comment:14 Changed 10 years ago by sev-

What is the status of this item?

comment:15 Changed 10 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:16 Changed 10 years ago by sev-

Priority: normalhigh

comment:17 Changed 9 years ago by fingolfin

Using the comi.s05 savegame spookypeanut attached last, *before* the room with the problem is loaded, I cannot reproduce the issue. I.e. I load it, I talk to LeChuck, making him turn me into a kid. Then the fair is loaded -- and the sky patch is not clickable. This is with current trunk.

spookypeanut, you wrote that you could reproduce it from that save? Is that still the case? Maybe you used a specific set of conversation choices? In any case, right now this looks to me like a one-time savegame error (granted, a corrupt savegame is always a bad sign...).

comment:18 Changed 9 years ago by fingolfin

Status: newpending

comment:19 Changed 9 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:20 Changed 9 years ago by SF/sf-robot

Status: pendingclosed

comment:21 Changed 9 years ago by spookypeanut

Status: closednew

comment:22 Changed 9 years ago by spookypeanut

Apologies for the delay, RL is taking its toll atm. I just reproduced the bug from that save game at the start of the act, with trunk. V odd. I'll now note down my exact conversation choices...

comment:23 Changed 9 years ago by spookypeanut

"What's so special..."
"But how..."
"But if you..."
"I've heard enough..."
"Did somebody..."
* Open door
* Talk to Dinghy Dog
"How can I win..."
"Bet you can't guess..."
"Give me that anchor"
* Take anchor
* Make fake pie, put it on stack
* Open gate

I'm beginning to think this might be specific to my version? Will do some tests...

Changed 9 years ago by spookypeanut

Attachment: comi.md5 added

Result of "find | xargs md5sum"

comment:24 Changed 9 years ago by spookypeanut

Well, I've just tested in my ogg compressed version, my uncompressed version, and a fresh copy straight from the CDs, and all have this issue. According to the readme.txt, this is version 1.0 of the game. I've attached an MD5 list of all files, in case it helps.

comment:25 Changed 9 years ago by fingolfin

Thanks for getting back to me.

I can reproduce the issue now -- the key is actually making the "fake pie" (in retrospect this is maybe not so surprising ;). I.e. the moment I use the shaving cream on the pan, the sky triangle becomes clickable.

I don't have time to analyze this further right now, but this might give somebody else a clue for further investigations.

I'll attach a savegame from which this is easy to reproduce.

Changed 9 years ago by fingolfin

Attachment: comi.s70 added

save game before creating "fake pie pan"

comment:26 Changed 8 years ago by fingolfin

Owner: fingolfin deleted

comment:27 Changed 7 years ago by sev-

Priority: highnormal
Note: See TracTickets for help on using tickets.