Opened 12 years ago

Closed 12 years ago

#3444 closed defect (fixed)

NIPPON: Masking(?) - Donna doesn\'t disguise as Suzy (Amiga)

Reported by: (none) Owned by: peres
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 0.11.0svn (Oct 29 2007 22:15:21)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

When Donna has attended Figaro at the "Lucky Look" she
should walk around disguised as Suzy Yong with a new
hairdo in an unspeakable color :-)
Well, she doesn't.
As soon as she rises from Figaros chair her hair is
back to normal. It only changes to Suzy's do when in
"automatic mode" (that is when the user can't control
the character), like when Donna is going to the street
from "Hot Sushi". The character is taken over by the
engine to become smaller and walk to "square". When
the scene has changed to the newspaper stand, Donna is
back to normal again (Masking bug?)

Nippon Safes Inc. (Amiga/Multilingial)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1822819. Ticket imported from: bugs/3444.

Attachments (1)

game.4 (321 bytes) - added by SF/*anonymous 12 years ago.
Walk out and in the "Lucky Look", get a new style

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by SF/*anonymous

Attachment: game.4 added

Walk out and in the "Lucky Look", get a new style

comment:1 Changed 12 years ago by (none)

That bug is also messing up the later game.
As soon as Donna swims to freedom from the residence the
dye should be washed out and Donna back to normal, but she
still is drawn with the Suzy hairdo when the engine takes
over.

comment:2 Changed 12 years ago by peres

Owner: set to peres
Summary: NIPPON: Masking(?) - Donna doesn't disguise as Suzy (Amiga)NIPPON: Masking(?) - Donna doesn\'t disguise as Suzy (Amiga)

comment:3 Changed 12 years ago by (none)

Confirmed HALF fixed :-)

She disguises now, but after climbing from the water and
rubbing the dye out she stand for a milisecond with her
brown locks and immediately changes into the disguise again

comment:4 Changed 12 years ago by (none)

Confirmed fixed in r29373

Thanks peres

comment:5 Changed 12 years ago by bluegr

This bug seems to be resolved, can it be closed?

comment:6 Changed 12 years ago by peres

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.