Opened 12 years ago

Closed 12 years ago

#3427 closed defect (invalid)

PSP: Monkey Island SegaCD dialog menu

Reported by: SF/thegreatsaint Owned by: joostp
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Just got Scummvm working on my psp. My Monkey Island game works good on the PC. However, after loading the game and getting to the dialog on my psp I am unable to change the dialog choices.

The compatablity list on the Scummvm website states that you can change dialog choices on Monkey Island by using the scoll wheel on your mouse.

What control do I use to change the dialog choices on the psp? Could this be a firmware issue?

Ticket imported from: #1811273. Ticket imported from: bugs/3427.

Attachments (1)

scummvm_savegames.zip (49.8 KB ) - added by SF/thegreatsaint 12 years ago.
save files

Download all attachments as: .zip

Change History (11)

comment:1 by fingolfin, 12 years ago

Owner: set to joostp

comment:2 by fingolfin, 12 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

by SF/thegreatsaint, 12 years ago

Attachment: scummvm_savegames.zip added

save files

comment:3 by SF/thegreatsaint, 12 years ago

Using an English Sega CD version of the game.
Scummvm-0.10.0-psp
Placed the single-eboot version of the scummvm-0.10.0-psp into the GAME folder.
game loaded, dialog choices would not change
Deleted the single-eboot version
Tried the 1.5-eboot version in the GAME150 folder.
same issue, tried every control, could not get dialog choices to change.
Tried the PC version, You can change the dialog choices (on the sega CD version) by moving the mouse wheel (WxP)
Scummvm-0.9.1-psp (save file attached)
Scummvm-0.9.0-psp
Placed the 1.5-eboot version in the GAME150 folder
same issue, can't choose any dialog except the first choice.

Haven't found a version that works yet.

File Added: scummvm_savegames.zip

comment:4 by joostp, 12 years ago

I don't own the SegaCD version of MI1, but if the scroll-wheel of a mouse is the only way of selecting dialog, then, no, it won't work on a PSP. No need to try any different/older versions of the port.

Seeing as the game on SegaCD didn't require a scroll-wheel, or even a mouse, I'd be surprised if there was no other input mechanism.

comment:5 by joostp, 12 years ago

Summary: PSP: Monkey Island dialog menuPSP: Monkey Island SegaCD dialog menu

comment:6 by fingolfin, 12 years ago

Ahhh, it's the super-extra-special SEGA version of MI, that explains a lot ;). We had lots of "fun" adding support for dialog scrolling there in the past.

Essentially, the 6 and 7 keys can be used for scrolling; we also remap the arrow keys for that purpose. Joost, if you want to add some extra mappings for that game in the PSP version, refer to scumm/input.cpp (search for SEGA), and also bug #1193185.

comment:7 by joostp, 12 years ago

I see.
Adding support for arrow keys (and possibly remappable ones) is something that is planned - the million dollar question is when I will have the time for it, though :-/

thegreatsaint, as Fingolfin said, it's probably possible to scroll using '6' and '7' of the Virtual Keyboard now, but I imagine it won't really be a pleasant gaming experience that way...

comment:8 by SF/thegreatsaint, 12 years ago

Hey, Thanks guys.

I'm happy just knowing I can change the dialog choices with 6 & 7 (maybe putting this on compatibility list would be nice). I played the game for 20 minutes the other day choosing just the first dialog choices

Anyways, I'll experiment moving my save files to PC, If I do get stuck I can always use PC to get past that point. Because the psp's wide screen makes the game that much more enjoyable I won't be spending that much time using the Pc version.

Keep up the good work guys

comment:9 by fingolfin, 12 years ago

Resolution: invalid
Status: newclosed

comment:10 by fingolfin, 12 years ago

I am closing this, as there is no actual bug here, at most a feature request for mapping the arrow keys.

Note: See TracTickets for help on using tickets.