Opened 12 years ago

Closed 12 years ago

#3423 closed defect (fixed)

NIPPON: Unexpected Quit when entering a screen (Amiga)

Reported by: (none) Owned by: peres
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 0.11.0svn (Oct 6 2007 01:02:08)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

If Donna walks into the "Lane" in Tyoko the very first
time the game/ScummVM silently quits spitting out only

unknown statement 'ENDCOMMANDS' in zone posta!n script

No crash, though

Playing with Donna

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

In the save game.5 just walk to the "Lane" (NE)

Ticket imported from: #1808615. Ticket imported from: bugs/3423.

Attachments (1)

game.5 (129 bytes ) - added by SF/*anonymous 12 years ago.
Just walk to the Lane

Download all attachments as: .zip

Change History (4)

by SF/*anonymous, 12 years ago

Attachment: game.5 added

Just walk to the Lane

comment:1 by fingolfin, 12 years ago

Owner: set to peres

comment:2 by peres, 12 years ago

Resolution: fixed
Status: newclosed

comment:3 by peres, 12 years ago

This is caused by an unexpected 'ENDCOMMANDS' in the script. I relaxed the parser policy to avoid crashes when it encounters such an unmatched statement in zone definitions in r29158.

Note: See TracTickets for help on using tickets.