Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3417 closed defect (fixed)

MONKEY: Mouse is invisible after loading

Reported by: SF/glinari Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

I have a strange behaviour with the secret of Monkey island running on ScummVM.

If I load a saved game, I can't see the pointer of mouse.
This happens for every saved game.

If I start a new game, it works normally.

I run ScummVM 0.10.0 on Windows XP Sp2.

Ticket imported from: #1804278. Ticket imported from: bugs/3417.

Attachments (1)

monkey-vga-it.s06 (16.9 KB ) - added by SF/glinari 12 years ago.
One saved game, copied from my home PC to my work PC

Download all attachments as: .zip

Change History (14)

comment:1 by eriktorbjorn, 12 years ago

There are a number of things which may or may not matter to the problem.

Which version of the game is this? There were three different ones for the PC alone (the old 16-colour version, the 256-colour floppy version, and the CD version), and that doesn't take the various translations into account.

When save/load, do you use ScummVM's GUI (the F5 key), or the "quick save/load" keys, Alt 0-9 and Ctrl 0-9.

Do you run the game in fullscreen or windowed mode? Do you use any of the scalers and/or aspect-ratio correction?

I can't reproduce the problem with my savegames and the English 256-colour PC versions. Could you attach one of your savegames?

comment:2 by fingolfin, 12 years ago

Status: newpending
Summary: Mouse problemMONKEY: Mouse problem

by SF/glinari, 12 years ago

Attachment: monkey-vga-it.s06 added

One saved game, copied from my home PC to my work PC

comment:3 by SF/glinari, 12 years ago

1 - I'm not sure that the following one, will be the correct answer:
Monkey Island
ID: monkey-vga-it-1
Name. The Secret of Monkey Island (VGA/DOS/Italian)
Language: Italian
Platform: DOS (I try also Amiga and nothing about my problem changed).
Colors settings 256.

2 - I used the F5 option.

3 - Both. In both mode i have the error.
Also in this case I tried both with "Aspect Ratio Connection" enabled and disabled. In both mode I have the error.

4 - I uploaded one of these

File Added: monkey-vga-it.s06

comment:4 by SF/glinari, 12 years ago

Status: pendingnew

comment:5 by eriktorbjorn, 12 years ago

Odd. I can't test your savegame since I only have the English version, and savegames are generally not portable across different translations. (I can load it, but the game crashes immediately.)

Does it happen with all your savegames, or just this one? (I don't know where in the game this is saved, but if you save during a cutscene - when the cursor is hidden - it will of course remain hidden when the savegame is reloaded, until the cutscene has ended.)

The _grabbedCursor image (which is where the cursor image is stored) seems to be all transparent after loading your savegame, but even if that would make a difference, ScummVM should keep re-creating the cross-hair cursor with different colours to animate it. Though if the cursor is hidden, that probably wouldn't help...

comment:6 by SF/glinari, 12 years ago

Thank you the same

Unfortunately this happens with all my 6 saved games.

The first attempt to solve this issue was exactly to load a previous saved game and re-start from it:
At the beginning I couldn't believe to have the same problem. Next, when I tried with all others saved games, I was depressed.
The most unbelievable thing is that if I start a new game this doesn't happen.
I'm an IT consultant so I can understand all the trouble to solve these kind of problems.

Now I'm uncomplaining.
I'm playing without the pointer of mouse.
It's quite difficult, but it works.

I don't understand the question about The _grabbedCursor image, if you have a bit of time, could you explain me better?

Thanks in advance

comment:7 by eriktorbjorn, 12 years ago

It wasn't so much a question as thinking out loud. The _grabbedCursor buffer is where the SCUMM engine stores the current cursor image. It's needed mostly for later games, where the cursor image changes depending on what you do. (It changes in Monkey Island 1, too, but only the colour.)

I was surprised that the _grabbedCursor buffer seemed to hold a completely invisible cursor, and I was surprised that the engine didn't re-create a visible cursor immediately. The only explanation I could think of was that it does re-create the cursor, but that it has been told to hide it. But I don't know why.

comment:8 by fingolfin, 12 years ago

Just to clarify: If you start a new game, the cursor is visible, right?

Now, if you save from this new game, and then later load that save game -- does this work correctly, too? Or is the mouse cursor invisible then, too?

comment:9 by fingolfin, 12 years ago

Summary: MONKEY: Mouse problemMONKEY: Mouse is invisible after loading

comment:10 by sev-, 12 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:11 by sev-, 12 years ago

We've had similar bugreport #1752196.

Unfortunately there is no way how to find out how you managed to make ScummVM overwrite _vm->_cursorImages. That means that there is no way to cleanly prevent this from happening in the future. So if you will happen to know when cursor started to disappear, that would be really nice.

In the meantime I added new debugger command. So switch to debugger by pressing ~ (tilde), and type in "resetcursors" and hit Enter. That should bring the cursor back after loading incorrect save.

comment:12 by fingolfin, 12 years ago

This might be related to bug #1508095...

comment:13 by SF/glinari, 12 years ago

Thanks for suggestions.

I will try your solutions and I'll keep you update.

Note: See TracTickets for help on using tickets.