Opened 13 years ago

Closed 13 years ago

Last modified 20 months ago

#3414 closed defect (fixed)

Oddity in Makefile.common

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

Latest ScummVM SVN

If I compile ScummVM shortly after rebooting my computer, I get a warning message like this:

make: Warning: File `/dev/null' has modification time 3,4e+03 s in the future

The most likely explanation I've heard is that /dev/null is created, or maybe just accessed, before the system has set the correct time zone.

This in itself is, of course, not a bug in ScummVM. However, I'm curious about this which I found at the end of Makefile.common:

# Include the dependency tracking files. We add /dev/null at the end # of the list to avoid a warning/error if no .d file exist -include $(wildcard $(addsuffix /*.d,$(DEPDIRS))) /dev/null

Is the inclusion of /dev/null actually necessary here? According to the documentation for GNU Make 3.81, the very purpose of using "-include" instead of "include" is to suppress errors and warnings.

Ticket imported from: #1803020. Ticket imported from: bugs/3414.

Change History (6)

comment:1 by fingolfin, 13 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 13 years ago

Hmm, I am pretty sure I used to see warnings (errors?) w/o it in the past, but back then I was still using 3.79. Well, if it works fine for you (no warnings/errors after removing /dev/null and a full "make distclean && ./configure", then by all means remove it :-)

comment:3 by eriktorbjorn, 13 years ago

It works for me. Could you try too, in case I've made some silly error?

comment:4 by fingolfin, 13 years ago

Works fine for me, fix commited.

comment:5 by fingolfin, 13 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 20 months ago

Component: --Unset----Other--
Note: See TracTickets for help on using tickets.