Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#3411 closed defect (invalid)

COMI: Extremely odd bug

Reported by: SF/thunderpeel2001 Owned by: digitall
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Monkey Island 3

Description

Hi there, I've come across a bug playing CMI in "normal" mode that could have easily drifted under the radar and which unfortunately requires some research from kindly souls with time.

This is the bug: I've arrived on Blood Island. Griswold Goodsoup has mentioned that the door to the lodger's room has been locked because it's haunted. Guybrush is given the dialogue tree to ask if he'll open it for him. Griswold replies he won't, it must stay locked, etc. Except in NORMAL mode it's already open!

Supplied is a save where you can see the bug (and it IS a bug, despite how it might sound). I'm just not sure if it's always been present in CMI.

Tested on Vista/O.X.O.

Edit: Problems uploading save... file too small??

Ticket imported from: #1800740. Ticket imported from: bugs/3411.

Attachments (3)

comi.s45.zip (100.8 KB) - added by SF/thunderpeel2001 12 years ago.
Weird bug surrounding the unlocking of the upstairs door in NORMAL mode
comi.s14 (112.1 KB) - added by digitall 9 years ago.
ScummVM savegame for replication
savegame.020.zip (122.0 KB) - added by digitall 9 years ago.
Original engine savegame for replication

Download all attachments as: .zip

Change History (19)

comment:1 Changed 12 years ago by SF/thunderpeel2001

Save file here:

http://www.thunderpeel2001.com/files/comi.s45

comment:2 Changed 12 years ago by fingolfin

Summary: CMI: Extremely odd bugCOMI: Extremely odd bug

comment:3 Changed 12 years ago by fingolfin

Just to clarify: Are you saying this is a bug in ScummVM (i.e. it behaves differently with the original .exe) ? Or that this is a bug in the game itself?

comment:4 Changed 12 years ago by bluegr

According to the original post here:
http://forums.scummvm.org/viewtopic.php?t=4284
he doesn't know if it's a bug in ScummVM or in the original game itself, so he's asking for people to test it with the original interpreter

comment:5 Changed 12 years ago by SF/thunderpeel2001

Sorry for not making it clear, but thebluegr is indeed correct; I am unable to test this bug with the original interpreter (I think). The easiest way to understand the problem is to load the save and then go upstairs (in the game).

Hopefully someone will eventually get to the bottom of this odd one! I've looked around a pretty extensive list of existing bugs for CMI (http://www.worldofmi.com/features/trivia/errors.php?game=MI3&s=1) and I've not seen it anywhere. I can only speculate that it's ScummVM.

Changed 12 years ago by SF/thunderpeel2001

Attachment: comi.s45.zip added

Weird bug surrounding the unlocking of the upstairs door in NORMAL mode

comment:6 Changed 12 years ago by SF/thunderpeel2001

Also, no-one has mentioned this here (although it may be talked about elsewhere) you can not upload ScummVM save files. You get the error message that the file must be over 20Kb. I've added some cruddy text to inflate a zip file and uploaded it now.
File Added: comi.s45.zip

comment:7 Changed 12 years ago by fingolfin

By the nature of this bug, it *seems* quite unlikely to be a caused by a bug in ScummVM, it rather looks like a genuine script bug. Hence I am reluctant to spend any work on investigating this before somebody confirmed (by actually trying it) that the original engine did not show the very same behavior. Speculating that this is not the cause just because this bug is not listed somewhere already is, sadly, not conclusive at all :-).

comment:8 Changed 12 years ago by sev-

John, can you test it with original?

comment:9 Changed 12 years ago by sev-

Status: newpending

comment:10 Changed 12 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:11 Changed 12 years ago by SF/sf-robot

Status: pendingclosed

comment:12 Changed 12 years ago by SF/thunderpeel2001

If I find the time, I'll try and check it. But, of course, anyone else can check it too! :)

comment:13 Changed 10 years ago by Kirben

Status: closednew

comment:14 Changed 9 years ago by digitall

Have playtested for this with :
ScummVM 1.2.0svn49267 (May 27 2010 21:15:43)
Features compiled in: Vorbis FLAC MP3 ALSA RGB zLib FluidSynth
and original interpreter.

This bug occurs in the original interpreter identically to ScummVM, so this is a bug in the
dialogue scripts, rather than a regression.

I have attached savegames from the original interpreter and my ScummVM svn build to
allow this to be easily verified.

Changed 9 years ago by digitall

Attachment: comi.s14 added

ScummVM savegame for replication

Changed 9 years ago by digitall

Attachment: savegame.020.zip added

Original engine savegame for replication

comment:15 Changed 9 years ago by wjp

Added to wiki SCUMM/Bugs and closing.

comment:16 Changed 9 years ago by wjp

Keywords: original added
Owner: set to digitall
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.