Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3395 closed defect (fixed)

GOB3: graphic glitch in the ship

Reported by: SF/glorifindel Owned by: DrMcCoy
Priority: low Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

Hi, I'm using WinXP and the latest 0.11 SVN build with Goblins 3 (italian CD version) I've encountered a little graphical glitch in the very first playable room of this game: if you jump in the barrel and jump again in the ship (see the screenshot for the spot) the Blount sprite is incorrectly positioned behind a background element.

(another possible glitch I've notice: the mouse cursor turn pink in the cut-scene where Blount meet Winonna, not sure it'sa bug...)

Ticket imported from: #1787354. Ticket imported from: bugs/3395.

Attachments (2)

scummvm00000.png (24.9 KB ) - added by SF/glorifindel 13 years ago.
Graphic glitch in the ship
scummvm00001.png (16.2 KB ) - added by SF/glorifindel 13 years ago.
Pink mouse cursor

Download all attachments as: .zip

Change History (10)

by SF/glorifindel, 13 years ago

Attachment: scummvm00000.png added

Graphic glitch in the ship

by SF/glorifindel, 13 years ago

Attachment: scummvm00001.png added

Pink mouse cursor

comment:1 by SF/glorifindel, 13 years ago

File Added: scummvm00001.png

comment:2 by DrMcCoy, 13 years ago

The problem isn't that the mouse cursor is pink, but that the cursor is showing at all (it shouldn't). It's an instance of the cursor visibility issue.

The first one seems to be a "real" problem with the sprite drawing orders.

comment:3 by DrMcCoy, 13 years ago

Owner: set to DrMcCoy

comment:4 by sev-, 13 years ago

What is the status of this item?

comment:5 by DrMcCoy, 13 years ago

Priority: normallow

comment:6 by DrMcCoy, 13 years ago

The Blount-Barrel glitch is still there. It's pretty minimal though, so I'll lower the priority.

comment:7 by DrMcCoy, 12 years ago

Fixed in the SVN repo.

comment:8 by DrMcCoy, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.