Opened 12 years ago

Closed 12 years ago

#3377 closed defect (invalid)

WINCE : BS1 : cutscene runs slow

Reported by: SF/stimmscumm Owned by: SF/knakos
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

Pocket PC : HTC TyTn
OS : Windows Mobile 6 Profesional
Free Ram : 25 mb
Free main memory : 34.5 mb
Scummvm version : 0.10.0

There is something happening related to gapi and its happening in all games cutscene when there is a lot of moviment/action on the cutscenes. In broken sword 1 and 2 the cutscene movie are very slow in Full Throttle the action cutscene are not shown at all i can only hear the audio and when the cutscene is finished continue the game.

Ticket imported from: #1773911. Ticket imported from: bugs/3377.

Attachments (2)

scummvm_stderr.txt (8.7 KB ) - added by SF/stimmscumm 12 years ago.
scummvm_stdout.txt (837 bytes ) - added by SF/stimmscumm 12 years ago.

Download all attachments as: .zip

Change History (10)

by SF/stimmscumm, 12 years ago

Attachment: scummvm_stderr.txt added

by SF/stimmscumm, 12 years ago

Attachment: scummvm_stdout.txt added

comment:1 by SF/stimmscumm, 12 years ago

File Added: scummvm_stdout.txt

comment:2 by SF/knakos, 12 years ago

Owner: set to SF/knakos

comment:3 by SF/knakos, 12 years ago

BS: are you using the dxa scene pack or the mpeg2 pack? dxa packing performs much better.

FT: You can try the method mentioned here: http://forums.scummvm.org/viewtopic.php?t=4181
to get better performance.

comment:4 by SF/stimmscumm, 12 years ago

the problem happened when i was using the mpeg2 pack, but after i read the thread at the forum i downloaded the dxa pack from scummvm site and the problem was solved. In the lucasarts games i tested with the dig the configuration Smush_force_redraw=10
sound_thread_priority=0 and it seems to be working fine. ill test with full throttle later and post the results. Knakos thyanks for the tips and by the way i m reading the forum a lot lately and i would like to congratulates you for your excelent work. Keep it up dude.

May the force be with all scummvm team and players

comment:5 by SF/stimmscumm, 12 years ago

tested the config Smush_force_redraw=10 sound_thread_priority=0 right now and it worked fine the cutscene movies are now playing very well. So the conclusion for tytn users are : with broken sword 1 use the dxa pack insted of the mepg2. woth the lucas arts in general use the config Smush_force_redraw=10 sound_thread_priority=0 and the cutscenes will work fine. But how about broken sowrd 2 ? is there a dxa pack for it ?

comment:6 by SF/stimmscumm, 12 years ago

i checked the site and saw the dxa pack for bs 2 sorry i missed it before. well one more time thank you very much for creating scummvm and to keep it alive. For me it is one of the best game simulator ever made.

comment:7 by SF/knakos, 12 years ago

Resolution: invalid
Status: newclosed

comment:8 by SF/knakos, 12 years ago

sure, scummvm r0cksz :-)

Closing. (invalid = not a bug)

Note: See TracTickets for help on using tickets.