Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3375 closed defect (duplicate)

WINCE: GOB3: Crash when looking at object

Reported by: spookypeanut Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

Just trying to run gob3 on my PocketLOOX N560, but it crashes on the first screen.

To reproduce:
Load up the game, skip the intro, then click on the hook (or the thing that's holding the hook to the wall). Slight pause, then ScummVM disappears, and windows says "sorry, the application caused an error" etc. I tried to find a way to save the error report that it tries to send to Microsoft, but couldn't. I can take photos of it if it will help.

I have included the debugging files (tho I can't see anything of use in there).

Ticket imported from: #1772692. Ticket imported from: bugs/3375.

Attachments (3)

scummvm_stderr.txt (731 bytes ) - added by spookypeanut 12 years ago.
stderr debugging output
scummvm_stdout.txt (402 bytes ) - added by spookypeanut 12 years ago.
stdout
scummvm_stdout.2.txt (174.6 KB ) - added by spookypeanut 12 years ago.
stdout with debugflags set properly

Download all attachments as: .zip

Change History (8)

by spookypeanut, 12 years ago

Attachment: scummvm_stderr.txt added

stderr debugging output

by spookypeanut, 12 years ago

Attachment: scummvm_stdout.txt added

stdout

comment:1 by spookypeanut, 12 years ago

File Added: scummvm_stdout.txt

comment:2 by DrMcCoy, 12 years ago

Owner: set to DrMcCoy
Resolution: duplicate
Status: newclosed

comment:3 by DrMcCoy, 12 years ago

Since I see IMD-related output, I assume it's the CD version. I think that would be connected to bug #1742029:
https://sourceforge.net/tracker/?func=detail&aid=1742029&group_id=37116&atid=418820

So I'm closing that as duplicate. Could you add to that report that it's happening on WinCE too?
Ah, and if it's possible, could you run ScummVM with "-d1 --debugflags=DrawOpcodes,FuncOpcodes" and attach the output there?

A backtrace would be nice, too, if there's a way to run a debugger like gdb or maybe even valgrind.

comment:4 by spookypeanut, 12 years ago

With knakos' help, I think I've managed to get the debug info you need. Unfortunately it was while I had debug level set to 3 (rather than 1), hope that doesn't matter. Let me know if you need anything else.

Note: I didn't seem to be able to attach it to the correct bug report (maybe because I didn't start it?), so I've attached it here.
File Added: scummvm_stdout.txt

by spookypeanut, 12 years ago

Attachment: scummvm_stdout.2.txt added

stdout with debugflags set properly

comment:5 by spookypeanut, 12 years ago

FuncOpcode != FuncOpcodes

Reattached, hopefully correct this time.
File Added: scummvm_stdout.txt

Note: See TracTickets for help on using tickets.