Opened 17 years ago

Closed 17 years ago

Last modified 12 months ago

#336 closed defect (fixed)

BeOS compilation error

Reported by: SF/kreeblah Owned by: fingolfin
Priority: normal Component: Port: BeOS
Keywords: Cc:
Game:

Description

When compiling ScummVM from a CVS pull from a few minutes ago,
I received this error when make hit dialog.cpp:

g++ -Wp,-MMD,".deps/dialog.d2" -g -O -Wall -Wstrict-prototypes
-Wuninitialized -Wno-long-long -Wno-multichar -DUNIX -I./ -I.
/sound `sdl-config --cflags` -c gui/dialog.cpp -o gui/dialog.o
In file included from /boot/develop/headers/cpp/
stl_alloc.h:42,
from /boot/develop/headers/cpp/alloc.h:21,
from /boot/develop/headers/cpp/std/
bastring.h:39,
from /boot/develop/headers/cpp/string:6,
from /boot/home/newsc/scummvm/gui/
ListWidget.h:27,
from /boot/home/newsc/scummvm/gui/
dialog.cpp:27:
/boot/develop/tools/gnupro/lib/gcc-lib/i586-beos/2.9-beos-
991026/include/new:40: declaration of `operator new(long
unsigned int)' throws different exceptions
/boot/home/newsc/scummvm/scummsys.h:340: previous declaration
here

Ticket imported from: #579945. Ticket imported from: bugs/336.

Change History (7)

comment:1 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 17 years ago

What version of GCC is that?

It obviously works fine with my gcc 2.95.2, but at the
Solaris boxen in Uni I get the same problem (they use GCC 3
there). The problem is that our operator new has a different
signature than the one the Std C++ lib expects. I'll look
into this.

comment:3 by fingolfin, 17 years ago

SHould be fixed in CVS now, please test it.

comment:4 by SF/kreeblah, 17 years ago

It builds now. :^)

The version of GCC that I'm using is the one that came bundled with
BeOS (so, I did a native build). I'm having trouble finding what
version it was ported from, though. gcc --version just spits out
2.9-beos-991026 so it's something in the 2.9x tree. I just can't
find out what . . .

comment:5 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed

comment:6 by fingolfin, 17 years ago

That's OK. The interesting part is more the version of the
Std C++ lib rather than the version of the compiler.

comment:7 by digitall, 12 months ago

Component: --Unset--Port: BeOS
Note: See TracTickets for help on using tickets.