Opened 12 years ago

Closed 12 years ago

#3353 closed defect

WINCE: FT: Unable to allocate memory in credits

Reported by: spookypeanut Owned by: SF/knakos
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Using 0.10.0 on a PocketLOOX N560 (VGA). Same issue with and without vorbis compressed audio.

Watching the credits at the end of Full Throttle, ScummVM gets to the end of one of the songs (the one that's playing while the voice cast starts, the first song I think), and then gives up with the following error:

ERROR: (153:438:0x37): Out of memory while allocating 481732

I went and checked how much free memory my device has and, assuming I'm looking at the right number, it's 30MB. So that shouldn't be an issue. I tried the same thing on Linux and followed its memory usage and there didn't seem to be anything wrong there.

I think it must be a slow leak, cos if I save it just before that point and reload, it doesn't happen (though I did save on linux and load on wince, maybe that made a difference).

Ticket imported from: #1764058. Ticket imported from: bugs/3353.

Attachments (2)

ft.s20 (17.2 KB ) - added by spookypeanut 12 years ago.
Savegame from start of credits
ft.s27 (19.8 KB ) - added by spookypeanut 12 years ago.
Save game from the end of the funeral

Download all attachments as: .zip

Change History (9)

by spookypeanut, 12 years ago

Attachment: ft.s20 added

Savegame from start of credits

comment:1 by SF/knakos, 12 years ago

So, by loading the attached savegame it is probable that I won't be able to reproduce the crash in wince?

comment:2 by SF/knakos, 12 years ago

Owner: set to SF/knakos

by spookypeanut, 12 years ago

Attachment: ft.s27 added

Save game from the end of the funeral

comment:3 by spookypeanut, 12 years ago

Sorry, I'll try to make myself clearer. I thought, when I wrote the description, that the save I'd attached worked, but on double checking this morning it doesn't seem to. Sorry for wasting your time.

I've attached a new one, and I've tried this one three times from a
cold start. Unfortunately you have to sit through the end of the
funeral, the car scene AND the first song of the credits (I think I
know them by heart now). Sitting through all this until the end of the
first song in the credits (around the time when "The Vultures" voice
actors come up) reliably reproduces the bug, at least on my device.
File Added: ft.s27

comment:4 by fingolfin, 12 years ago

Interesting. If it's a slow leak, it should be possible to find it on a regular PC, too...

comment:5 by SF/knakos, 12 years ago

This might be a leak, yes, or memory fragmentation coupled with the increasing size of the scummvm executable. I am going to tackle this (and the rest of the bugs) as soon as I finish investigation for a plugin architecture for the wince port. This has been going behind schedule due to RL commitments, but I plan to resume work on this very soon.

comment:6 by SF/knakos, 12 years ago

Status: newclosed

comment:7 by SF/knakos, 12 years ago

This is definitely a low memory problem. WM5 leaves about 16MB (or 13MB in the phone edition) free for applications, which simply are not enough for the multiple vga buffers we require. This can only be fixed by enabling the plugins and introducing the new low memory scheme proposed in -devel. I am closing this with 'Postponed' status - it will be addressed when the new infrastructure is in place.

Note: See TracTickets for help on using tickets.