Opened 17 years ago

Closed 17 years ago

Last modified 11 months ago

#335 closed defect (invalid)

Random lockups when loading bad games

Reported by: SF/quietust Owned by: SF/ender
Priority: high Component: Port: Win32
Keywords: Cc:
Game:

Description

Running under Windows 2000 SP2.

This has happened to me 3 times so far, once with
0.2.0 and twice with various CVS snapshots (whose
version numbers I do not recall).

Upon attempting to run the program (either with a
working game, a non-working game, or a game it
doesn't even recognize), ScummVM locked the system
hard - the hard drive light was on solid, yet there was no
disk activity, and the mouse and keyboard stopped
responding, forcing me to push the reset button. The
last time this happened, I was running as a user
with 'Power User' privileges (as opposed to
Administrative privileges), and it still managed to lock
the system.

I observed the lockups when attempting to run Amiga
Monkey1 and Amiga Indy3 (which are both apparently
unsupported) with various settings.

All 3 times it happened, it locked almost immediately
after the ScummVM window opened, but before it could
print any error messages. Also, I had successfully run
other games within ScummVM before having this
problem. After rebooting, attempting to re-run the games
that had caused the lockups would work 'properly' (i.e.
would run the game or error out gracefully).

The problem is rather rare (I suspect it's being triggered
by something in SDL.DLL), but no program should
*ever* lock Windows 2000 like that (especially when not
running with Admin privileges).

Ticket imported from: #579636. Ticket imported from: bugs/335.

Change History (7)

comment:1 by SF/quietust, 17 years ago

Component: Engine: SCUMM--Unset--
Game: Day of the Tentacle

comment:2 by fingolfin, 17 years ago

Priority: normalhigh

comment:3 by fingolfin, 17 years ago

This is strange, indeed. Seems nobody else right now is able
to reproduce it, though (at least of those people I asked).

Can you please tell us a bit more about your config (i.e.
what processor/OS version/graphic card/DirectX version/what
else you can think of that might be of importance).

comment:4 by SF/quietust, 17 years ago

733MHz Pentium III, 512MB PC133 SDRAM (CAS2)
As I said before, running Windows 2000 SP2, with all latest
updates installed.
Video: PNY Verto - 64MB GeForce3 Ti 200 with Detonator
28.32, DirectX 8.1
Disk: 2 * 100GB Western Digital WD1000BB, 3 partitions, 1
with software striping (ScummVM resides on a non-striped
partition)
Software: Apache 2.0.39 HTTPD, PHP 4.3.0-dev, MySQL
3.23.51, VNC 3.3.3 R9, Outlook XP, 2 instances of mIRC,
ICQ, Motherboard Monitor 5.1.0.7, NAV 2000 Corporate,
Belkin UPS monitor, and background services

It's only happened about 3 times in the past few weeks, and I
haven't had problems from any other programs.

comment:5 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: invalid
Status: newclosed

comment:6 by SF/ender, 17 years ago

This is so rare, its not a problem we can do anything about - nor anything
that appears to be caused by ScummVM.
If it's a SDL problem, then it's a problem related to your video card drivers.

Closing

comment:7 by digitall, 11 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.