Opened 18 years ago

Closed 18 years ago

#331 closed defect (worksforme)

DOTT: Can't get teeth

Reported by: SF/arricc Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

DOTT Floppy disk version PocketScumm Build 051302 (VM 051302)

Once the chattering teeth get trapped in the the grating, you can't pick them up. The only hot spot showing in the area is the grating.

Hopefully I've got the right file attatched for the savegame!

Ticket imported from: #576884. Ticket imported from: bugs/331.

Attachments (2)

SAVEGAME.001 (38.1 KB ) - added by SF/arricc 18 years ago.
Savegame
tentacle.s03 (48.8 KB ) - added by SF/arricc 18 years ago.
Savegame for Pocket PC

Download all attachments as: .zip

Change History (17)

by SF/arricc, 18 years ago

Attachment: SAVEGAME.001 added

Savegame

comment:1 by SF/ender, 18 years ago

Sorry, but thats a saved game from the original DOS version :)

ScummVM saved games are named 'tentacle.s00' - 'tentacle.s99'

by SF/arricc, 18 years ago

Attachment: tentacle.s03 added

Savegame for Pocket PC

comment:2 by SF/arricc, 18 years ago

Ah! tried to work out what it should have been, and failed ;-)

Oh, and I'm running it under Pocket PC on a Compaq iPaq 3850.

comment:3 by fingolfin, 18 years ago

Can't reproduce this with current build on Mac OS X.

comment:4 by fingolfin, 18 years ago

Will email arisme to look into this, maybe it is PocketSCUMM specific.

comment:5 by SF/arisme, 18 years ago

reproduced it on my windows build from this old CVS... will try with the latest

comment:6 by SF/arisme, 18 years ago

problem seems to be here (object.cpp)

if (!_objs[i].obj_nr || getClass(_objs[i].obj_nr, 32)) continue;

where the getClass condition is not verified for the chattering teeth (object 6)

guess I'll let someone with a better understanding of ScummVM internals handle that one :)

comment:7 by SF/arisme, 18 years ago

uh, in findObject function, forgot that one :)

comment:8 by fingolfin, 18 years ago

But it works for me - so how can it be a bug in the normal ScummVM code?

Arisme, did you try this on normal Windows or with PocketScumm?

comment:9 by SF/arisme, 18 years ago

I checked it on Windows ... but I haven't traced when the class of this object was modified, perhaps the savegame got corrupted somehow (or there is an endianess problem, or another weird thing :))

comment:10 by SF/rev3nant, 18 years ago

Using the latest build and still can`t pick up this damn teeth :(

comment:11 by fingolfin, 18 years ago

Using the same savegame? If yes, could you please try to reproduce this with a new game from scratch?

I can't reproduce this with any of my savegames nor with a new game.

I also can't use your save game, trying so causes a segfault for me.

comment:12 by fingolfin, 18 years ago

What is the status of this? So far I have failed to find anybody besides arisme and arricc who can reproduce it.

comment:13 by wjp, 18 years ago

Loading the supplied savegame segfaults for me. I can't reproduce the problem when starting a new game. (current CVS, Linux)

comment:14 by wjp, 18 years ago

Re. my previous comment: using the CD version of DOTT.

comment:15 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.