Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3308 closed defect (fixed)

ITE: p2_a.iaf not played correctly

Reported by: SF/noizert Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

The patch file is not played correctly when voices.rsc is compressed. If the voices file isn't compressed the file playes fine.

Ticket imported from: #1751344. Ticket imported from: bugs/3308.

Change History (16)

comment:1 Changed 12 years ago by bluegr

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 Changed 12 years ago by bluegr

Component: Engine: SAGA
Game: Inherit the Earth
Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:3 Changed 12 years ago by bluegr

Fixed in the latest SVN

Please, next time, include the required information and place the bug in the appropriate group (I've done this for this one). This was a very bad example of a bug report, with very little data, which made it much harder to track the bug

Closing

comment:4 Changed 12 years ago by SF/noizert

Sorry for the bad report.
Bug still exists. The patch file just gives a squeeky sound.
Again the file works fine when the other sound files are not compressed.

Using latest win32 daily build (23 july).
English CD DOS version of ITE.

comment:5 Changed 12 years ago by SF/noizert

Status: closednew

comment:6 Changed 12 years ago by bluegr

Try again with the latest SVN version please

comment:7 Changed 12 years ago by bluegr

Status: newpending

comment:8 Changed 12 years ago by bluegr

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:9 Changed 12 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:10 Changed 12 years ago by SF/sf-robot

Status: pendingclosed

comment:11 Changed 12 years ago by SF/noizert

Problem still exist with latest win32 build, 26 aug.

comment:12 Changed 12 years ago by SF/noizert

Status: closednew

comment:13 Changed 12 years ago by bluegr

Where is the patch file located? It should be under sound/p2_a.iaf, not the root directory of the game

comment:14 Changed 12 years ago by SF/noizert

It was located in the root. Once I moved it to SOUND directory, the problem is solved.
Thanks.

comment:15 Changed 12 years ago by bluegr

Aha so that was the issue. Fixed in the latest SVN, p2_a.iaf/p2_a.voc files located in the game's root folder are treated as uncompressed files now as well

Closing

comment:16 Changed 12 years ago by bluegr

Status: newclosed
Note: See TracTickets for help on using tickets.