Opened 12 years ago

Closed 12 years ago

#3307 closed defect (fixed)

TOUCHE: graphic glitch when saving/loading in Notre Dame

Reported by: SF/glorifindel Owned by: cyxx
Priority: normal Component: Engine: Touche
Keywords: Cc:
Game: Touché: The Adventures of the Fifth Musketeer

Description

Hi, i'm using ScummVM 0.10.0 WIN and the cd version of Touche (with the italian patch)

If you save a game outside of Notre Dame and load it, a graphic glitches will occur (see screenshot attached)

Ticket imported from: #1751226. Ticket imported from: bugs/3307.

Attachments (8)

scummvm00004.png (126.4 KB ) - added by SF/glorifindel 12 years ago.
touche.3 (4.7 KB ) - added by SF/glorifindel 12 years ago.
scummvm00001.png (123.0 KB ) - added by SF/glorifindel 12 years ago.
scummvm00000.png (172.8 KB ) - added by SF/glorifindel 12 years ago.
scummvm00000.2.png (172.8 KB ) - added by SF/glorifindel 12 years ago.
Another 2 places where the glitch occurs
savegames.zip (10.2 KB ) - added by SF/glorifindel 12 years ago.
bug.gif (66.1 KB ) - added by SF/glorifindel 12 years ago.
Bug animation
touche.10 (5.4 KB ) - added by SF/glorifindel 12 years ago.
DaVinci boat savagame

Download all attachments as: .zip

Change History (26)

by SF/glorifindel, 12 years ago

Attachment: scummvm00004.png added

by SF/glorifindel, 12 years ago

Attachment: touche.3 added

comment:1 by SF/glorifindel, 12 years ago

File Added: touche.3

comment:2 by fingolfin, 12 years ago

Owner: set to cyxx

by SF/glorifindel, 12 years ago

Attachment: scummvm00001.png added

comment:3 by SF/glorifindel, 12 years ago

This bug occur also when saving/loading in Rouen after using hammer with ladder(see screenshot)
File Added: scummvm00001.png

comment:4 by SF/glorifindel, 12 years ago

Component: Engine: Touche
Game: Touché: The Adventures of the Fifth Musketeer

by SF/glorifindel, 12 years ago

Attachment: scummvm00000.png added

comment:5 by SF/glorifindel, 12 years ago

Two further place where the glitch occurs (see screenshot)
File Added: scummvm00000.png

by SF/glorifindel, 12 years ago

Attachment: scummvm00000.2.png added

Another 2 places where the glitch occurs

comment:6 by SF/glorifindel, 12 years ago

Two further place where the glitch occurs (see screenshot)
File Added: scummvm00000.png

comment:7 by SF/glorifindel, 12 years ago

(sorry for the double post)

comment:8 by sev-, 12 years ago

May you, please, also attach saves for each of those places, so it will be easier for Gregory to reproduce?

by SF/glorifindel, 12 years ago

Attachment: savegames.zip added

comment:9 by SF/glorifindel, 12 years ago

Oh, sorry, i've forgotten them
File Added: savegames.zip

by SF/glorifindel, 12 years ago

Attachment: bug.gif added

Bug animation

comment:10 by SF/glorifindel, 12 years ago

Another little glitch when saving/loading: try to load the savegame attached (touche.10, DaVinci boat) and then reload again, you will notice that the water "animation spot" seems to move some pixel down... animated gif included ;-)
File Added: bug.gif

by SF/glorifindel, 12 years ago

Attachment: touche.10 added

DaVinci boat savagame

comment:11 by SF/glorifindel, 12 years ago

File Added: touche.10

comment:12 by cyxx, 12 years ago

Status: newpending

comment:13 by cyxx, 12 years ago

Should be fixed in SVN.

comment:14 by SF/glorifindel, 12 years ago

Status: pendingnew

comment:15 by SF/glorifindel, 12 years ago

Ok, bug resolved, thank you

comment:16 by SF/glorifindel, 12 years ago

(Not sure, but it seems that now if you load a game the actors and other objects are displayed a little after the room background, maybe it's a regression?)

comment:17 by cyxx, 12 years ago

Resolution: fixed
Status: newclosed

comment:18 by cyxx, 12 years ago

Indeed, should be fixed now with latest SVN.

Note: See TracTickets for help on using tickets.