Opened 12 years ago

Closed 12 years ago

Last modified 12 months ago

#3294 closed defect (worksforme)

WINCE: Halt on Dell Axim x50v

Reported by: SF/denisdmitriev Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

ScummVM 0.10.0-WinCE halts on Dell Axim x50v.

Immediately after starting scummvm hatls the PDA. No response from screen, keys etc. Only the soft reset helps. Setting debuglevel to 1 is of no help, no debug output file created. Tried several times, with and w/o scummvm.ini, with and w/o modern.*

Config: Windows 2003 SE, ROM version A05, no true-VGA hacks installed, screen in portrait mode. Will be happy to provide any additional details.

Downgrading to 0.9.1 works fine.

Ticket imported from: #1748915. Ticket imported from: bugs/3294.

Change History (9)

comment:1 by fingolfin, 12 years ago

Owner: set to SF/knakos
Summary: Halt on Dell Axim x50vWINCE: Halt on Dell Axim x50v

comment:2 by SF/knakos, 12 years ago

scummvm has a good record on running in x50v devices, so I tend to think that there is no problem on scummvm's end. Since you're on a 2003 device, how much free RAM memory have you left for scummvm? It should be 12-13 MB upward. Can you try increasing that (if it applies)? That "cannot exit cleanly" situation certainly makes debugging harder :-(

comment:3 by SF/denisdmitriev, 12 years ago

Just tested with as much free RAM as possible. It was approx. 7 MB free storage data and 26 MB free program memory. Same story. I understand that there are people who is able to run ScummVM 0.10 on x50v. Moreover, it confuses me a lot

comment:4 by SF/knakos, 12 years ago

Hmmm, let's see. I would suggest checking for dell official patches and/or firmware updates or also putting in a more compatible gapi library. Please search around for those. Also, do other games/GAPI applications work alright for you?

BTW, the free ram you report is ample for scummvm's purposes.

comment:5 by SF/denisdmitriev, 12 years ago

I do not use any GAPI tweaks, only the native one. However, I just tried GAPI tweak 1.11 from emulamer. Didn't help either.

Hower, scumm started OK right after hard reset. So, the problem is in my specific config. Please, close the bug if you wish or, leave it for a while, I'll try to find out the reason and post it here. Any clues how to figure this out are appreciated.

comment:6 by SF/knakos, 12 years ago

Resolution: worksforme
Status: newclosed

comment:7 by SF/knakos, 12 years ago

OK then, I'm closing this for statistic reasons, and so that I don't get anxious whenever I log in sf.net :-) But please, feel free to post a reply when (if) you find out what's the problem.

comment:8 by Strangerke, 6 years ago

Component: --Unset--Ports

comment:9 by digitall, 12 months ago

Component: PortsPort: WinCE
Note: See TracTickets for help on using tickets.