Opened 12 years ago

Closed 9 years ago

#3281 closed defect (fixed)

ELVIRA2: Crash with items from dinning room

Reported by: SF/clerynka Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Elvira 2

Description

Elvira II English PC/DOS version
Elvira II German PC/DOS version
Elvira II English Amiga version

so i think it could be in all language on Amiga/PC platform Bugs

a report from few days of checking..

ScummVM 0.x.0 PSP

Everythings are allright until ive created a Courage spell

A game crashes in Haunted House (studio 2) in dinning room
when i create a spell in this room (from 2 wine flasks)
other crash is when i get this flasks, leave a dinning room and create this spell - then everything was ok.... but it isnt - i cant go to dinning room because of crash.

Im trying right now check this again on scumm PC port
0.11.0 Scumm PC Win32

On scumm PC port a game crashes too. Additionaly a game crashes when im creating a Detect Trap spell from a wine glass founded in dinning room.

MINOR BUG ON BOTH: when experience are above 1000 then second number from right are strange first i think it's a psp port issue, but on PC this hapen again

tested on files from Elvira II Dos EN from horrorpack and standalone Acollade version

ANOTHER MINOR BUG: I dont understand when a P.P. should be recovered sometimes recovering selves - sometimes not i have no idea why. It looks like a P.P. recovering after some times of playing when a level or one from parameters are changed. Then P.P. are recoverying until a SAVE/RESTORE because after restore savegame a P.P. are freezing again.

ONCE AGAIN MINOR BUG: Usualy after save restore - a spell who was active example - defense or courage are freezed so when i cast courage spell and i save game and restore game there is big possibility for a permanent having raised up statistics.

--------------------------------

now ill try an amiga version... but only on PC because PSP port working too slow with amiga version of Elvira/Elvira 2

amiga version has this problems too.

tested with 0.X.0 and 0.11.0

... a courage spell is needed in 3 moments of game, but 2 of them could be passed with save/restore when your (tested)

1 a moment when in dinner room you looking at plate with head... loss of consciousness but it isnt necesary for gameplay (save/restore)

2 when you try go out from kitchen and a zombie was attack you. sometimes you have loss of consciousnessloose and you wake up in the kitchen. just save before and try again

3 when you are on second floor a room with red bed. You have a dream and after you wake up a nightmare comming.... i can't pass this moment right now by save/restore

--------------------------------------------------

im attaching zip with 2 save files

1 from PC version (file 001) UK
2 from amiga version (file 002) SMETARZ

both are ENG , and crashing when create a courage spell (wine bottles) or detect trap spell (wine glass)

Sorry for my english

tested with SCUMM PC win32 0.11.0svn (jun 30 2007 16:53:01)

Ticket imported from: #1745996. Ticket imported from: bugs/3281.

Attachments (2)

elviraII.zip (12.0 KB) - added by SF/clerynka 12 years ago.
savefiles from amiga and pc version
elvira2.007 (5.9 KB) - added by SF/clerynka 12 years ago.
filename - poczatek, create detect trap or courage :)

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by SF/clerynka

Attachment: elviraII.zip added

savefiles from amiga and pc version

comment:1 Changed 12 years ago by SF/clerynka

A MINOR BUG with EXP above 1000 no more exist in SCUMM PC win32 0.11.0svn (jun 30 2007 16:53:01) :)

comment:2 Changed 12 years ago by SF/clerynka

A MINOR BUG with EXP above 1000 no more exist in SCUMM PC win32 0.11.0svn (jun 30 2007 16:53:01) :)

comment:3 Changed 12 years ago by fingolfin

Owner: set to Kirben
Summary: Crash with items from dinning room (and minor spell bugs)ELVIRA2: Crash with items from dinning room

comment:4 Changed 12 years ago by fingolfin

Thank you for taking the time to report this.

But please, please, please: File one separate report for *each* issue you encounter (as we ask you to do on the "bug submission" page, too). Otherwise it is impossible to track your report, and it becomes very difficult for us to handle it.

comment:5 Changed 12 years ago by Kirben

Looking over the scripts used, I see why the problem occurs, but I can't locate a bug in the code. I wonder if this is a script bug in the original, as the problem is limited to any interaction with a specific item (Wine Bottles).

I added work around to ScummVM SVN, which will display warning in console, when this problem occurs. Please use the next snapshot of ScummVM 0.11.0svn and report any other locations, where you see the warning, to this bug report.

Changed 12 years ago by SF/clerynka

Attachment: elvira2.007 added

filename - poczatek, create detect trap or courage :)

comment:6 Changed 12 years ago by SF/clerynka

Checked with version 0.11.0svn (Jul 2 2007 19:22)

1 When im creating a Detect Trap spell from wine glasses taken from table (look at save)
2 When im creating a Couage Spell from wine bottles taken from table (look at save)
there may be more problems with items from this room (im not enough level at now to create other spells)

attached save file (filename in game - poczatek) filename elvira2.007

File Added: elvira2.007

comment:7 Changed 12 years ago by SF/clerynka

OK i Finished ALL the game and the ONLY place where i see this warning is a dinning room
at now there is a warning but all looks OK a spells created from dinning room items working normally.

a strange thing is... even if i used a spell somewhere in game and i go back to the dinning room without any spells that could be made from this items all warnings are still displayed (every warning for each created spell)
a) wine glass (detect trap spell LEV3)
b) wine bottles (courage spell LEV3)
c) (2 x silver candelabres - with silver four leaf clover from box in elvira room (Magical Armor LEV7)
d) cutlery, forks - with amethyst/blue crystal from studio 1 (lightning bolts LEV7)

with last daily version of scummPC ELVIRA 2 are playable and completable :) (there is a crash on end but it's another story) ;)

comment:8 Changed 12 years ago by Kirben

Thanks for testing the complete game, and the detailed reports.

Could you please add a separate bug report (with saved game), for the crash at the end of the game.

comment:9 Changed 10 years ago by fingolfin

Status: newpending

comment:10 Changed 10 years ago by fingolfin

What is the status of this item?

comment:11 Changed 10 years ago by Kirben

Status: pendingnew

comment:12 Changed 10 years ago by Kirben

Unchanged, there is currently a hack in ScummVM to work around this problem.

I'm still not sure why this problem doesn't occur in the original version, since I have not been able to locate any related code difference.

comment:13 Changed 9 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:14 Changed 9 years ago by fingolfin

The problem might not occur in the original version because the original run under DOS; and dereferencing NULL works there. So, no crash, and the error goes unnoticed. Various bugs in SCUMM game scripts are not noticeable in the original due to this.

Since a workaround has been implemented, and since it does not seem to adversely affect game play, I am closing this item. Sure, maybe there is some deeper bug behind this, but if so, we'll get more bug reports; and in any case, the nice WORKAROUND comment in the code will lead us back to this tracker item, should we need to revise it :-).

Note: See TracTickets for help on using tickets.