Opened 17 years ago

Closed 17 years ago

Last modified 13 years ago

#328 closed defect (worksforme)

SIMON: Barbarian overdrawn

Reported by: SF/madshi Owned by: Kirben
Priority: low Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Not a serious bug at all. The Barbarian in the forest,
which has that fragment in his foot. After giving the trill
whistle to Simon the Barbarian speaks some sentences
and than doesn't move anymore. However, the last
movements of the Barbarian are drawn over each other
without clearing the background. Looks a bit strange,
but no big thing...

Ticket imported from: #575619. Ticket imported from: bugs/328.

Change History (13)

comment:1 by fingolfin, 17 years ago

Priority: normallow

comment:2 by fingolfin, 17 years ago

Summary: SIMON1: Barbarian overdrawnSIMON: Barbarian overdrawn

comment:3 by Kirben, 17 years ago

Tried all three versions of Simon 1 and couldn't reproduce the
problem.

comment:4 by Kirben, 17 years ago

Owner: set to Kirben
Resolution: worksforme
Status: newclosed

comment:5 by SF/zorbid, 17 years ago

I've just seen a similar pronlem with the owl in the forest, with
the latest build (02-11-02).

comment:6 by SF/madshi, 17 years ago

Why don't you ask for confirmation before closing a bug
report? :-(

Here's a screen shot of how the barbarian looks like in the
beginning of the conversation (looks alright):

http://madshi.net/simon2.jpg

Here's how it looks like after the conversation with today's
daily build, reproducable with both of my german simon1win
versions:

http://madshi.net/simon.jpg

This isn't right. Can you see that? Some parts of the
barbarian are drawn twice. The background was not redrawn
correctly. No big thing, but it's still broken.

Anyway, thanx for your great work. Just noticed that now we
have music in Simon, was not there at the time when I
posted this bug report. So there is clearly progress... :-)

comment:7 by SF/zorbid, 17 years ago

As a side note, I'm using a french version, that you can get at
http://www.abandonware-france.org

comment:8 by Kirben, 17 years ago

I closed the bug because I could not re-produce that problem
on any of the english simon 1 verisons, the barbarian always
looks fine. I tried the barbarian saved game you provided in
another bug report in simon 1 dos, simon 1 dos talkie and
simon 1 win talkie.
Are you using a graphic filter in scummvm ? and if so which
one ?

comment:9 by SF/madshi, 17 years ago

The screenshots from yesterday were with yesterday's
current daily build in win32 with no options at all (except the
path to the CD, of course).

If I can help you with anything (testing, sending files,
whatever), you can contact me directly
at "scummvm@madshi.net".

Thank you!

comment:10 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: Kirben removed
Status: closednew

comment:11 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 2
Owner: set to Kirben
Status: newclosed

comment:12 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2Space Quest 2

comment:13 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.