Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3278 closed defect (fixed)

GR: Birds stuck in opening screen (Amiga version)

Reported by: (none) Owned by: SF/buddha_
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: Goldrush

Description

ScummVM 0.11.0svn (Jul 1 2007 08:51:56)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The birds in the background of the opening scene in
Boston are stuck. The won't move until one leaves the
screen and returns. But even then they still get stuck
in different places now and then.

Little not serious (script?) glitch

English Amiga Floppy

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1745950. Ticket imported from: bugs/3278.

Attachments (1)

GoldRush-1st-Screen.png (14.6 KB ) - added by SF/*anonymous 12 years ago.
1st Scene

Download all attachments as: .zip

Change History (10)

comment:1 by sev-, 12 years ago

Game: AGI FanmadeGoldrush
Summary: AGI: GoldRush (Amiga) - Birds stuck in opening screenGR: Birds stuck in opening screen (Amiga version)

comment:2 by bluegr, 12 years ago

Does this happen with the original interpreter as well?

comment:3 by (none), 12 years ago

You mean playing the game on an Amiga?

Nope, everything (including the birds) starts moving as
soon as the first scene comes up.

May be a timing bug (speed of the new interpreter compared
to the old?) because the birds start moving after a real
long time, but eventually get stuck again and start moving
again and so on...

Read here: http://www.allowe.com/Larry/troubleshooting.htm
Scroll down to Leisure Suit Larry 3

[quote]
No one (including me) ever dreamed that people would still
be playing Leisure Suit Larry 3 when computers were as fast
as they are today. Therefore, my "weight loss to time spent
exercising" algorithm in Fat City is totally hosed. On a
fast machine, you may never lose weight, no matter how many
hundred reps you do!
[/quote]

OK, this is not the same interpreter (SCI compared to AGI).
It's from a different series AND from a different coder,
but still, sometimes the most weird idea is the right.

...and i'm full of weird ideas :-)

comment:4 by bluegr, 12 years ago

This issue occurs in the Amiga version of the game, the birds move normally in the PC DOS version

by SF/*anonymous, 12 years ago

Attachment: GoldRush-1st-Screen.png added

1st Scene

comment:5 by (none), 12 years ago

At request of thebluegr heres the screenshot of the first scene
File Added: GoldRush-1st-Screen.png

comment:6 by SF/buddha_, 12 years ago

Owner: set to SF/buddha_

comment:7 by SF/buddha_, 12 years ago

It seems the Amiga version uses an unknown test command 19.

Tried running the Amiga version of Gold Rush! with Nagi and
it worked so took a look at Nagi's source code and it seems
it doesn't know what the test command 19 does either but just
evaluates it to false. So I tried the same approach and it
seems to work. So this is a quick fix, I don't know what the
command does in the Amiga executable so it is possible that
this may still prove to problematic in the future.

comment:8 by SF/buddha_, 12 years ago

Resolution: fixed
Status: newclosed

comment:9 by SF/buddha_, 12 years ago

This was properly fixed in the trunk by revision 30251
which implemented the unknown test command 19
(I named it unofficially as the in.motion.using.mouse-command).

Note: See TracTickets for help on using tickets.