Opened 12 years ago

Closed 12 years ago

Last modified 13 months ago

#3245 closed defect (wontfix)

OS X minimise button

Reported by: SF/mr_basic Owned by: fingolfin
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

ScummVM verison 0.9.1

build: Nov 8 2006 23:21:33

Mac OS X 10.4.9 PowerBook 12" G4

all works well but upon exiting scummvm fullscreen app (ctrl q), during running any game, all the minimise buttons on current open applications are disabled, restarting apps fixes problems, it seems that the vm disables minimise buttons globally and fails to reset upon exit.

100% reproducible.

only occurs when running game in fullscreen mode.

Cheers

Iain

Ticket imported from: #1735381. Ticket imported from: bugs/3245.

Change History (5)

comment:1 by bluegr, 12 years ago

This was caused by an older version of SDL itself. Refer to:
http://bugzilla.libsdl.org/show_bug.cgi?id=281
Have you tried this with ScummVM 0.10.0? It includes a newer version of SDL (SDL version 1.11.0), which should fix this problem

comment:2 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:3 by fingolfin, 12 years ago

Err, not quite, thebluegr. the correct answer is as follows:

The bug described here has been reported previously, however, it is a bug in the SDL library we use for displaying all our graphics etc. (and strictly speaking, it's a bug in Mac OS X which is uncovered by an unusual command sequence in SDL).
Unfortunately, all released versions of SDL, up to and including the latest, 1.2.11, are affected by this. We will try to build the upcoming 0.10.0 release (which, despite what thebluegr says, is not yet available) against a manually modified version of SDL which should solve this issue, even though it is not really our fault.

comment:4 by bluegr, 12 years ago

Hm, in SDL's bugtracker it was marked as a bug on SDL 1.2.10, which was presumsbly fixed in 1.2.11 :( Apologies, didn't know it still occurs in SDL 1.2.11 (it's not apparent in the bug report).

As for ScummVM 0.10.0, I should have phrased this as "try it with ScummVM 0.10.0 when it's released in a few days". It was late when I wrote this :/

At least I got the SDL bugreport right :P

comment:5 by digitall, 13 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.