Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3240 closed defect (duplicate)

INDY3: Music volume can not be set

Reported by: SF/arturmeinild Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

* ScummVM version *
scummvm-0.10.0svn-2007_05_27

* Bug details *
Music volume can not be set for the game in the options dialogue. I think the volume is always at max.

* Language of game *
English

* Version of game *
VGA version

* Platform and Compiler *
Pocket PC

* Since when *
This bug was not present in 0.9.1, but present in the first SVN build of
0.10.0 i got from 2007-05-02.

Ticket imported from: #1734071. Ticket imported from: bugs/3240.

Change History (19)

comment:1 Changed 12 years ago by SF/arturmeinild

Priority: normalhigh

comment:2 Changed 12 years ago by fingolfin

Is this really WinCE specific? Did you test whether this works better on a regular PC?

comment:3 Changed 12 years ago by fingolfin

Owner: set to SF/knakos
Priority: highnormal
Status: newpending
Summary: PPC/INDY3: Music volume can not be setWINCEINDY3: Music volume can not be set

comment:4 Changed 12 years ago by fingolfin

Summary: WINCEINDY3: Music volume can not be setWINCE INDY3: Music volume can not be set

comment:5 Changed 12 years ago by SF/arturmeinild

Hi! No I have not tested on a regular PC, but I can do that later today... Thanx.

comment:6 Changed 12 years ago by SF/arturmeinild

Status: pendingnew

comment:7 Changed 12 years ago by SF/arturmeinild

Status: newpending

comment:8 Changed 12 years ago by SF/knakos

Owner: SF/knakos deleted
Status: pendingnew
Summary: WINCE INDY3: Music volume can not be setINDY3: Music volume can not be set

comment:9 Changed 12 years ago by SF/knakos

As with the other one (#1734064), this also happens in the win32 build. I'm deassigning myself. Feel free to either close this one if this is a known issue/dupe, or reassign it to me if there are further problems.

In the meatime Arthur, you can adjust the volume before launching scummvm to a more comfortable level (e.g. 0 :-) ).

comment:10 Changed 12 years ago by SF/arturmeinild

Indeed, this is also present on the win32 build, so changed the title and status to open. Thanx.

comment:11 Changed 12 years ago by SF/arturmeinild

Owner: set to SF/knakos

comment:12 Changed 12 years ago by SF/arturmeinild

Owner: SF/knakos deleted

comment:13 Changed 12 years ago by SF/knakos

As with the other one (#1734064), this also happens in the win32 build. I'm deassigning myself. Feel free to either close this one if this is a known issue/dupe, or reassign it to me if there are further problems.

In the meatime Arthur, you can adjust the volume before launching scummvm to a more comfortable level (e.g. 0 :-) ).

comment:14 Changed 12 years ago by fingolfin

This bug is a duplicate of bug #1159581.

comment:15 Changed 12 years ago by fingolfin

Owner: set to fingolfin
Resolution: duplicate
Status: newclosed

comment:16 Changed 12 years ago by SF/arturmeinild

I'm 99% certain the music volume levels worked with Indy3 in version 0.9.1 - I remember testing it, and I remember being surprised that the music was suddenly very loud when going to the 0.10.0 build...

comment:17 Changed 12 years ago by SF/arturmeinild

Additionally, if it was duplicate of bug #1159581, then I presume the volume would work if I changed the sound driver to FM Towns on my PPC, but this isn't the case. No matter which sound driver I select, the music level is always MAX.

comment:18 Changed 12 years ago by fingolfin

You presume incorrectly; because your request for a different music driver is simply ignored by ScummVM.

comment:19 Changed 12 years ago by (none)

I can reproduce the same bug (music, sfx volume can not be set in the game or gui, it can only set of by choose no music option.) but in the symbian version 0.9.1 of csummvm and with indy3 german/dos/vga version. By indy4 i can set the music off only by choose no music option. By set 0, the music still play, but very quietly.

Note: See TracTickets for help on using tickets.